Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Just about all videos won't play!

  • @jimunderscorep said in Just about all videos won't play!:

    Why doesn't anyone try opera-BETA 50 with chromium 63 ffmpeg codecs installed, since they are both built from the same sources? Instead, you all try workarounds to extract, move to the right place etc chromium 62 ffmpeg codecs to make it work with chromium-62-based opera stable.

    Plus, if this really is the issue (the compatibility between the versions opera and chromium ffmpeg codecs are build), opera devs should move opera beta to stable faster. Chromium 63 reached stable at December 8th, so chromium-63-based opera beta should move to stable sooner.

    Because 50's a beta, which I worry might be a worse option that adapting 49, especially if not technically able to fix other things. I didn't know about the beta, either. Opera should be getting the criticism, as they must know these issues will happen due to not releasing the right codecs at the same time. Just glad to know the option of keeping previous codecs, so things work.

  • Here we go again!
    Updated Ubuntu today. There were some changes made to Opera 49, namely chromium ffmpeg codecs extra 63 replaced chromium ffmpeg codecs extra 62, making videos NOT play again.
    Just did again what I did before as shown below and videos are running again.
    @cybrsaylr said in Just about all videos won't play!:

    Success......I hope!

    Opened Synaptic Package Manager and removed chromium ffmpeg codecs extra 63.0.3239.84

    Then downloaded and installed codecs-ffmpeg-extra_62.0.3202.94 as per

    Restarted Opera 49.0 and videos are running again.

    However Synaptic now shows this:
    alt text

    Oh and it seems the new Opera VPN that presently offers only 3 regions does slow videos down quite a bit when turned on. When VPN is turned off videos play very well.

  • You have to unload the last chromium-ffmpeg-codecs-extra update and re-install an earlier one. The latest one (chromium-codecs-ffmpeg-extra_63.0.3239.84-0ubuntu0.14.04.1_amd64) won't work.

  • So, chromium-63-based opera 50 is out today. Can you all verify that chromium 63 ffmpeg codecs work now?
    I would, but I can't, because debian does not package chromium ffmpeg codecs.

  • Neither does Mageia ...

  • It seems that debian and mageia depend on the libav* libs (libavcodec/libavcodec-extra, libavformat and libavutil) instead of libffmpeg to provide the needed html5 support for chromium. I thought it was just debian, but after I checked chromium's dependencies on mageia, I am sure they do the same.

    How hard is it for opera devs to make opera use these libs as well instead of its own libffmpeg and the ones provided by chromium ffmpeg codecs (on the distros that do build and package them).

  • You can fix video in all recent Opera versions (under Debian at least) by downloading this

    And extracting the file from it and putting it into the directory /usr/lib/x86_64-linux-gnu/opera

  • Linux mint 18.3 offers 63.0.3239.132-0ubuntu0.16.04.1 ffmpeg codecs via update manager, do those work?
    I don't want to install them just to see if they work and if not, do all the work installing a earlier version.

  • Just a notice...
    Chromium 64 was released today, so it will soon be on in the repos of all major and minor distros, along with chromium codecs 64. In turn, they may (or may not) be compatible with today's opera 50, which is built on chromium 63. So, brace yourselves, whining about "videos not playing anymore" is coming :p

    This solution has been suggested many times in the past. I am against it as a solution because that is an ARCH linux package, built on totally different libs, ffmpeg etc. What if someone is on debian stable which has ffmpeg 3.2.x? What if he is on ubuntu 16.04 which has an even older version of ffmpeg? Using a "foreign" lib to just make things work seems like a pretty stupid idea to me...

    Opera 50 is chromium 63 based, so mint's chromium ffmpeg codecs should play with no problem. However, keep in mind what I said above.

  • Here we go again..........

    Running Opera 50.0.2762.67 - Opera is up to date.
    For about a week or so all videos were playing well, right up to today when all vids refuse to play again!

    This is getting pretty old. Wish Opera would address this chronic issue and solve it!

  • @jimunderscorep chromium codecs 64 is not compatible with today's opera 50.

  • @sigmalion said in Just about all videos won't play!:

    @jimunderscorep chromium codecs 64 is not compatible with today's opera 50.

    I know. Opera 50 is based on chromium 63, thus chromium 64 ffmpegs codes do nbt work with it.
    When I wrote that post above, ~2weeks ago, chromium 64 was just released and all distros still had chromium 63 on their repos. That's why I said "it will soon be in the repos etc..."

  • Does anyone finally solved this problem? This is starting to be highly annoying. I have to keep FireFox in my OS for such situations. Yesterday had to update my linux distro, saw opera and chromium codecs on the update lists and know that I'll be must using FireFox this week and I was right. Tried all solutions, I have chromium codecs repo and copy libmpeg from chromium codecs into Opera dir make Opera crashing over and over

  • Before I start writing about apt-mark and other apt kung-fu, what do you mean with this bit

    Tried all solutions, I have chromium codecs repo and copy libmpeg from chromium codecs into Opera dir

    Which is that "chromium codecs repo" you mention? And which distro are you on?

  • Everyone having problems with videos on Twitter (or GIFS) or with the H.264 codec videos. I'm running Opera 52 for Linux (Deepin 15, Ubuntu based).

    I downloaded the last libffmpeg version from this github repo:

    Just placed in the /usr/lib/x86_64-linux-gnu/opera and restarted Opera. All working like a charm! I've been searching for solutions like last 2,3 hours and finally found that solution. Hopes that helps some other Linux buddies here! 🙂

  • @dawy Thanks for that link. I downloaded it and tested it out. It works fine. However, it seemed a little big because it is unstripped. I stripped mine by strip -s first and that knocked it down to 2.5 megabytes. That is not necessary though.

  • Under Arch Linux and probably more the package name to fix this problem is "opera-ffmpeg-codecs" install that package and restart the Opera browser and the issue should be resolved.

  • For the ubuntu or ubuntu-based, this
    should work for those not wanting to manually drop a lib in the opera dir or opera/lib_extra dir.

  • Post for reference:

  • Here we again!

    Made the mistake of updating to Opera 52.0.2871.99 - Stable- Opera is up to date - on Ubuntu 16.04.4 LTS (x86_64; Unity), just a few minutes ago and now just about all videos DON'T play!

    Videos played fine before updating Opera......