Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • @pindos said in Linux 32 bit developed?:

    Opera develops 32 bit versions for Windows, but stopped do this for Linux.

    To be fair, most companies that develop closed source for linux today, make it available for 64bits only, eg viber, skype, chrome etc, so dropping 32bit support is no surprise. Plus, opera did not support 32bit back in 2013 when it switched from presto to blink, with version 15. 32bit support came a lot later, in early 2016 with opera 35

    Linux systems coverage has increased. We made Opera 35 Stable for 32bit platform architecture and we’re also adding RPM packages.

    And if having a browser for 32bit systems seems important to you, think that there are distros that have dropped their 32bit isos and repos a long time before opera.

  • @jimunderscorep
    I know that! And it's very sad. I can't use 64 bit OS on my EeePC. The CPU doesn't support this instructions. I can finely use Win10, but all browsers in Windows are too slow. The Opera - too.
    All right, you dropped the development for 32 bit Linux, but why the last version of Opera asks me to update? The annoying red menu button appears. Isn't it a bug of product. I can't update it anymore, but the program ask me to do that every time.

  • I feel you. I have dell's answer to the eeepc, a dell mini 9, which I use as a media player with kodi (openelec). Its 32bit-only cpu (atom n270) and its small drive forces me to have an old version of openelec (5.x), with an old version of kodi (14.x), old enough that most addons do not work properly or at all anymore. Hoever, I keep it because I do not have the money to upgrade to something better.

    As for the pointless update notification, it happens because it checks at some upstream version number online, not at what really exists in the repo. Sadly, there is no workaround for it, neither via opera://flags, nor via some command line switch.

    May I ask what keeps you in opera? You could move to chromium for instance...

  • disable update notification use parametr --disable-update
    run: opera --disable-update

  • @nikt11 ? I just downloaded Opera for Xubuntu Linux 32 bit yesterday and got version 12.16 . It says it's up to date, but the Themes utility doesn't recognize it. Where did you find 45? The .deb installer I downloaded from didn't work, so I followed the instructions at : cd && wget -O opera.key && sudo apt-key add opera.key && rm opera.key && echo "deb stable non-free" | sudo tee /etc/apt/sources.list.d/opera.list && sudo apt-get update && sudo apt-get install opera -y

  • @kghn "The .deb installer I downloaded from didn't work" what does that mean, what are the errors?
    I downloaded opera 45 from ftp: and install on Debian 9.2: dpkg -i opera-stable_45.0.2552.898_i386.deb
    Everything works fine. Debian 4.9.51-1 (2017-09-28) i686 GNU/Linux

  • @nikt11 when I open it, there's an install button. I click it, and it seems to react, and there's drive activity, but pretty soon it reverts to the unclicked-looking install button and never does anything more. No error message. Opera did not appear in the Xubuntu "mousehead" menu. I tried a couple of times. I'm not sure where to find an install log, if it writes one.

  • @kghn try install from console:
    sudo dpkg -i opera-stable_45.0.2552.898_i386.deb
    and see error messages

  • @nikt11 Thanks for your help so far! Here's my terminal text. I had to tell it where to find the file:
    gary@Desktop1:~$ sudo dpkg -i opera-stable_45.0.2552.898_i386.deb
    [sudo] password for gary:
    dpkg: error processing archive opera-stable_45.0.2552.898_i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    gary@Desktop1:~$ ls
    Desktop Documents Downloads Music Pictures Public Templates Videos
    ...trying again...
    gary@Desktop1:~$ sudo dpkg -i Desktop/Maintenance/opera-stable_45.0.2552.898_i386.deb
    Selecting previously unselected package opera-stable.
    dpkg: considering removing opera in favour of opera-stable ...
    dpkg: yes, will remove opera in favour of opera-stable
    (Reading database ... 226820 files and directories currently installed.)
    Preparing to unpack .../opera-stable_45.0.2552.898_i386.deb ...
    update-alternatives: using /usr/bin/firefox to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
    update-alternatives: using /usr/bin/firefox to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
    Unpacking opera-stable (45.0.2552.898) ...
    Setting up opera-stable (45.0.2552.898) ...
    update-alternatives: using /usr/bin/opera to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
    update-alternatives: warning: skip creation of /usr/share/man/man1/x-www-browser.1.gz because associated file /usr/share/man/man1/opera.1.gz (of link group x-www-browser) doesn't exist
    update-alternatives: using /usr/bin/opera to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
    update-alternatives: warning: skip creation of /usr/share/man/man1/gnome-www-browser.1.gz because associated file /usr/share/man/man1/opera.1.gz (of link group gnome-www-browser) doesn't exist
    Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
    Processing triggers for mime-support (3.59ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
    Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
    Processing triggers for man-db (2.7.5-1) ...

    It seemed to install ok, but on launch, I get an error window titled "Ubuntu" that says "The application Opera has closed unexpectedly." When I click the Details button, it says ExecutablePath /usr/lib/i386-linux-gnu/opera/opera and the processing swirly took a long time. Then: Package opera-stable 45.0.2552.898 [origin: Opera Software ASA]; ProblemType Crash; Title opera crashed with SIGILL; ApportVersion 2.20.1-0ubuntu2.10; Architecture i386; CoreDump actually says "(binary data)"; CurrentDesktop XFCE; Date Sat Nov 11 16:19:28 2017; Dependencies (has a long list, won't let me copy) ... much much more including JournalErrors ACPI Warning (several) and a long list of other items; ...UnreportableReason This is not an official Ubuntu package. Please remove any third party package and try again.
    Relaunch button gave same error window.

    I suspect version 45 needs something my machine doesn't have - more memory, ESS2, ? - or maybe I need to change some BIOS setting. The BIOS is still configured for XP, and Opera 12 seemed happy. Is there an Opera version between 12.16 and 45 that might be more appropriate? Or can you coach me to get this one working? Thanks again for your attention to my plight.

  • How much RAM does your system have?

  • @jimunderscorep said in Linux 32 bit developed?:

    May I ask what keeps you in opera? You could move to chromium for instance...

    I like Opera and use it for a 15 years. And does Chromium have support for 32 bit cpu for Linux?
    It,s very sad. I have EeePC 1003, I've upgraded it to 2GB of RAM, replaced HDD with Intel SSD 240 Gb and Wi-Fi Adapter. And only CPU is weak thing in this machine.

  • @pindos
    Unlike chrome, chromium is opensource, so distros package it in both 32 and 64 bits, so yes, chromium is available in 32bit.
    Which distro do you use?

  • I'm fine with old version. But every update of chromium-codes breaks it. Is there any way around this without keeping old codecs with security vulnerabilities? (Ubuntu 16.04 LTS i386 here)

  • @sgunhouse I'm working with an older machine (AMD Athlon XP 1800+ 1.53 GHz, 640M RAM, (originally ran XP) now running Xubuntu 16.04.3 LTS 32-bit. I've got a topic open at , and you just posted a good lead there for me. My plan for the next thing to try is to remove Opera and Firefox, install a desktop theme, re-install Opera 12.16, and report in with my results.

  • @jimunderscorep said in Linux 32 bit developed?:

    Unlike chrome, chromium is opensource, so distros package it in both 32 and 64 bits, so yes, chromium is available in 32bit.
    Which distro do you use?

    I use Xubuntu 16.04.

  • @pindos
    Then you can install it with
    sudo apt-get install chromium

  • @jimunderscorep
    Thank you! I'll try.

  • @jimunderscorep
    This command doesn't work.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package chromium is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:

    E: Package 'chromium' has no installation candidate

  • My bad, the package is named chromium-browser, so the right command is

    sudo apt-get install chromium-browser

  • @jimunderscorep said in Linux 32 bit developed?:

    sudo apt-get install chromium-browser

    That's right! Thank you! I installed it.