H.264 support (RPM-based Linux)

  • Fedora 27, GNOME , Opera 48.0.2685.52 (Stable) doesn't play html5 audio.

    Terminal writes:

    [1102/093741.347736:ERROR:render_media_log.cc(34)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"FFmpegDemuxer: open context failed"}
    [1102/093741.354404:ERROR:render_media_log.cc(34)] MediaEvent: PIPELINE_ERROR DEMUXER_ERROR_COULD_NOT_OPEN

    All codecs are installed. FFmpeg also installed. No effect.

    I've solved the problem this way (Chromium-browser installed):

    cp /usr/lib64/chromium-browser/libffmpeg.so ../opera/libffmpeg.so

    Just leave it here.

    By the way Ubuntu 17.10, GNOME, Opera 48.0.2685.52 (Stable) — no problems at all...
    Is problem in RPM-package?

  • Title corrected. I know my own Linux doesn't have proprietary codecs either.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.