Where is the close bar ???

  • Hello,

    I use Opera with Solus and before that with Fedora and I have a problem. Where is the bar with the close, hide and reduce button ? I searched all over the settings but found nothing related to this bar.

    I see this bar only when my window is reduced.

    Thank you in advance for your answere.

    PS: Sorry for my english but I'm french :)

  • See another thread on this issue - it depends on your window manager, not on Opera.

  • It depends only on Opera. All other applications have buttons to close, maximize or minimize window. Of course, window manager make some contribution, but developers of Opera do nothing to resolve it.
    P.S. I have another netbook with xubuntu 16.04. The window manager is the same, but Opera has one Close button (no maximize and minimize). So, I think it's a bug of Opera.

  • Yes, I think this is not related to my window manager because I also have the closing button sometimes when my window is reduced. I hope developers will fix it in futur.

    Thank you for your answer.

  • In the other thread, a user said it could be changed using the Window manager tweaks tool in xfce. that's what I was pointing at.

  • This not the same thing. That tweak in window manager makes the standard title bar visible. It's not in Opera style as you can see in Windows version, for example. The buttons must be on one line with tabs near the tab-menu button.

  • Are you on xfce?

  • @jimunderscorep
    Yes, I'm using xubuntu 16.04 with xfce.

  • As it seems, all users having this issue have been using xfce, so yes, opera is not to blame, xfce is.

    For the record, I am using openbox and I do not have that issue.

  • Likewise I have never seen it in KDE.

  • Why it's a bug of xfce? Opera developers make product to work on different distributives of Linux. Xfce is not rear desktop environment. To my mind the developers must test their product. As I have sad already, on another notebook with xfce there is one button to close Opera. Xfce is the same. Graphics driver is another. Maybe it depends on it. Or may be it is some incompatibility.
    I like this browser, but I can say that Opera for Windows has a lot of bugs too. That's why I have toblame Opera developers.

  • Ok, let me be more precise. It is a bug of opera which appears ONLY when it is run under xfce . And thats is because, according to all reports so far, it happens on all users who use xfce, regardless of the distro they use or any other setting, eg. compositing, driver in use, architecture etc, and not on everyone else.

    Some months ago, there was a similar issue on 45 for users who did not have compositing enabled (or installed at all) which made opera's menus look like crap. We mentioned in the forums, we exchanged opinions, we realised that the lack of compositing is the reason and opera devs fixed it... with a bad workaround imho.

    I would install xfce alongside openbox on my pc and post screenshots to prove my point, but I dont feel like doing so. Plus I can not do it on a virtual machine, because I do not have one handy.
    You can install another desktop enviroment on your distro, log in it and check for yourself. It does not have to be a full blown... bloat like kde or gnome, neither some hardcore stuff like plain openbox, just something simple like mate or lxde.

    Or, you could open a new thread (or use one of the 2-3 ones that already mention the problem), asking for feedback from xfce users and each one will post his stuff with screenshots and info, like distro, gpu driver in use, compositing on or off, etc and narrow things down to what it may be causing it.

  • It is Opera bug. I wrote in other thread, I have two virtual machines with Fedora + Xfce. First VM is not updating Fedora 22, installed maybe 3 years ago and second is always uptodate Fedora. Opera on first virtual machine HAD all buttons. And every new version of Opera removed some buttons. Xfce was not changing, only Opera was changing. So the missing buttons is matter of Opera and not desktop manager. And we know how often is Xfce updated...

  • But they still use xfce, new or old. And yes I do know how slow xfce releases are.

    Since you do have some virtual machines available and running, try installing a different desktop enviroment on one and check how opera runs there as well. If not, wait until I decide to install xfce on my debian installation and check myself.

  • @jimunderscorep I already have XFCE on my Mageia install. One thing to note, since the browser uses your desktop's secure storage, I can't access any of my saved passwords while in XFCE, since they are all stored in KDE. But on the current question ... if I Maximize Opera in XFCE, I have no "chrome" at all - but if I right-click on the taskbar icon (whatever XFCE calls their equivalent of a taskbar) then I get the regular window menu including "Unmaximize" which restores Opera to its usual window. Also, the standard keyboard shortcut Alt+spacebar displays the same menu.

  • If this is an xfce desktop: Settings -> Window Manager Tweaks > Accessibility, and uncheck the checkbox on the left of "Hide frame of windows when maximized".
    This was from a previous post and worked for me.

  • @dan6
    This tweak is only a workaround of the problem. It adds a standard window border with title bar and buttons on it. But these buttons must be in the right corner of tab bar. I have installed chromium-browser. And there is no such bug in it.

  • Different themes in the ARCH version of XFCE have different button configurations and some that let you remove or rearrange buttons. There are four buttons on the right side of my title bar: rollup, minimize, maximize, and exit. One button on the left fo the title bar. Using the Fullscreen option does not get full screen out of opera. It just wipes out my two task bars, one on top and one on bottom of my screen and kills the title bar on opera. Toggling F11 puts opera in a true Fullscreen mode and another F11 puts everything back to normal. Opera is not doing what it is supposed to do in terms of handling button routines correctly. Happy bug hunting folks! The Fullscreen option on the title bar is not tied to the same code as the F11 key.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.