Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

New Hisense TV pre loaded Plex app not working

  • Hello,
    My in-laws bought a Hisense 48 inch 4k smart TV yesterday. I set it up for them today and everything with the exception of the pre installed Plex app works. My in-laws live in a flat connected to our house and are on the same network. The Plex app launched and I was able to link it using the link code provided. However, when Plex is launched it doesn't connect saying that Plex tried to connect to 2 different IP addresses (one of which is the fixed IP address of the Plex server), provides a couple of links about Plex cannot find server and then the option to retry or go back.

    I can connect to the Plex server using DLNA on the TV and everything works fine. Plex also works perfectly on our LG TV running webos, Windows 10 PC's & android phones. I have read quite a bit of information about Plex not working on some TV's and that the Plex app has been removed from the Opera TV store. Can someone please let me know if Plex on Opera TV is not working so I don't spend more countless hours trying to get it to work.
    Thanks in Advance.

  • It worked until this weekend. A new update on the Opera store (3.8.0?) has destroyed the Plex app functionality when used through the Hisense TVs. Plex has washed their hands of it as they claim that they don't officially support Hisense TVs.

    More info here: