maximized mode has a border around it

  • Opera 45 (45.0.2552.881)
    Windows 7 64 bit
    no anti virus, etc.
    All extensions disabled.
    Triple Monitor (resolution: 5760x1080)
    Maximized mode (not F11 full screen mode) has a border around it as seen in the following image. Is there a way to correct this?

    http://www.animeviews.com/images/pops/1.jpg

  • When has started this behavior?
    Any recent changes?

    You may try with a Private window Ctrl+Shift+N or a clean profile or download this as a clean profile.

  • This has been occuring ever since I added two other monitors several months ago. CTRL + Shift + N has no effect. Clean profile using the link you provided had no effect either. The border still exists in all cases. F11 does work however.

  • I am getting closer to figuring this out. It has to do with theme settings for Windows 7 and probably later. To remove the border you need to set Active Window Border to 0. Currently, the lowest possible value is 1. I am trying to figure out how to set it to 0.

  • Registry then.

  • I already tried that, but thanks for the suggestion. It may be a bit, but if and when I figure it out I will post my solution here.

  • OK, so far I have learned that the border is a resizable border that is in effect when using multiple monitors on Windows 7 (at least) with Nvidia "Span displays with Surround" checked.

    The resizable border is useless since the browser can't be moved to other monitors when Surround is enabled and the browser is maximized. This appears to be a bug with Chromium since it appears with Google Chrome as well. This does not appear with IE.

    I will try to post again when I learn more.

  • Good!
    At least you found the cause.

    Thanks for sharing. 馃槈

  • Closing observations: It may be possible to fix this with exotic custom themes using the free WindowBlinds 10 (compatible with Windows 7 as well as 10). The paid version will allow users to create custom themes. Another option is to look into editing Windows shell files or possibly with command line switches.

    http://peter.sh/experiments/chromium-command-line-switches/

    http://www.stardock.com/products/windowblinds/

    I plan to stop digging further into this issue here.

  • I've read that nVidia surround is some complex to install, if it's right installed on your PC then make a Bug report, should work fine even with default themes.

  • I decided to look into this a little more. The borders that I see around Opera when maximized is seen in all windows including internet explorer or notepad when "span displays with surround" is turned on. I understand this as an Nvidia issue.

    The span displays with surround is very useful, if not required, when playing games in full screen across all browsers. This also means that a user needs to be able to switch between using three displays separately when not gaming to "span displays with surround" quite frequently which requires many steps each time.

    Oddly enough, using span displays with surround also plays havoc with the start menu when the start menu is not on the left most display. The colors and transparency can make many items difficult and sometimes impossible to read.

    One helpful thread is https://forums.geforce.com/default/topic/523424/nvidia-surround/switching-between-surround-and-34-standard-34-in-a-non-painful-way-/

    Here are a few promising links I am looking into:

    https://www.displayfusion.com/Compare/ $25
    DisplayFusion allows for easily toggling between display profiles.

    http://www.stardock.com/products/windowblinds/download $10
    WindowBlinds allows for greater control over Windows themes.

    http://www.splitview.com $39
    Allows surround mode to behave like multiple displays. Less of a fan of this option, but worth mentioning.

    Currently, I have keyboard shortcuts in the Nvidia control panel turned on. This allows me to use "ctrl+alt+s" to switch from standard to surround. This same command does not allow me to switch back to standard for some reason. To easily switch back to standard I go to Nvidia control panel, click on "Configure Surround, PhysX", click on the Configure button, and then click on "disable surround" button.

    There should be an easier way to do this which is apparently possible with DisplayFusion, however, I have not tried it yet and I am somewhat reluctant to pay the $25 to try it out although there is a free trial period.

    Anyway, this is where I am at so far. I'll probably dabble around with all of this a little bit more before I leave things be.

  • That's rare since nVidia graphics are supposed to support multi screen in most cases.

    Should be a switch off shorcut or maybe they are not aware about how many apps using sides as menus, tabs... :whistle:

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.