NoFlash: Troubles viewing .pdf files on the Opera browser

  • Version:	    44.0.2510.857 - Opera is up to date
    Update stream:	Stable
    System:        	Ubuntu 16.04.2 LTS (x86_64; Unity)
    

    Greetings,

    I am having hard time trying to view .pdf documents on the Opera browser. I have currently pepperflash-nonfreeplugin installed together with chromium-codecs-ffmpeg-extra and the NoFlash add-on. The flash applications (...for now) seem to be running just fine, but when I try to view a .pdf document on the browser, NoFlash gives me the following alert:

    Flash Content!
    Click to Activate Flash
    

    So far everything is as it should be, but when I click to activate the flash however ... well, nothing happens. The screen just turns dark gray and that's it! I still remember from the good old days when Opera allowed to view the plugins installed through opera://plugins, that a .pdf reader is installed on my system indeed.

    Is this another Opera update-related problem, and should one just wait or is there a way to fix it?

    Thanks a lot everybody! Cheers!

  • NoFlash is blocking PDFs? The two (Flash and PDF files) are not related, there should be a way for the extension to distinguish between them. (Check the extension settings.) But make sure that "Open PDF documents in default PDF viewer" is disabled in Settings while you're at it.

  • Hello @jayaguru-shishya,

    Things that come to my mind: 1, you shouldn't need pepperflashplugin-nonfree, and 2, can you disable NoFlash and see if you still have problems? If NoFlash is complaining, this seems more a bug on their side, rather than Opera's.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.