Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hi, everytime I try to go to Google app (that is simply a Opera Tv Browser tab already pointed to google url) or to browse to Google start search page with Opera TV Browser, a blank page appears, where just for 1 second flash Google policy about privacy with the "Next" button, but I'm not able to click it and going forward, and this page refreshes in a infinite loop.
    I also tried to go directly to Google account creation page, creating a new account, or login with an existing one, but when I insert the password, the page refresh again in the sing in page asking the email. The strange thing is that everytime I try this step, on pc and smartphone a get an email alert that tell me there was an access with my Google account from a Opera for Linux browser.

    This is the pic that shows the situation:

    I've already tried to remove and add Google and Internet Browser from the smart tv app, but I got same situation.
    Smart Tv is a Hitachi one, model 32HB2W66I. Hitachi support, doesn't know what to do.


  • Update:
    Hitachi support suggested me to try a factory reset, so I did.

    Now I can browse with Google app and Opera Tv Browser, just for searching for example. But I can't still sing in on my Google account, to check my Gmail or edit notes on Google Keep, and so on....

    I've the same problem notified on this closed discussion:

    that hasn't solution.

    I can login and the account is stored on Facebook and Youtube app.

    Any idea or suggestion?

    Thanks a lot

  • Despite the brand...

  • Hi Tulving. did you get your problem resolved?. The link suggested by Zalex seems to just show someone else with the same problem.
    I also have exactly the same problem (as per your screen shot) with Google search on my Celcus TV, so any answers would be greatly appreciated.

  • I thought I was buying a smart tv. Hisense Opera browser is junk. I see on this forum people have been complaining about it for over a year.
    I can't get Bigpond Movies, I can't get Google Play, I can't get anything I actually want. No rental movies at all, only the poor selection of dated stuff on Netflix Australia. It doesn't seem to matter that I will actually pay good money for these services.

    I thought I was buying an Android TV, but now I have to connect it to my laptop to get movies.

    Googles Play tells me I dont even have a TV connected - they think it is an iPad.

    Hisense sales are going to go down down down once people wake up to this. I am VERY DISAPPOINTED.

  • I have been looking for a solution for ages and only just seen you people relate to what my issue is, literally can't click any links in them browser because as soon as the page loads it refreshes automatically. It's really bugging me