no sound in opera

  • Hi. I installed Debian Stretch. Then latest opera 43. No probs with the sound anywhere, Chrome tested fine. But no sound in opera. Closing all tabs, clearing history - no changes.
    When i start playing sound - opera appears in pavucontrol as if it tries to play a sound, but then dissapears in a second or two.
    I couldn't find configuration of sound in opera settings anywhere.
    Can you please give me any advise what i can do to fix it? Thanks a lot

    opera-stable 43.0.2442.991
    linux-image-amd64 4.9+78
    pulseaudio 10.0-1

  • Hi,

    Opera no longer supports the Netscape plugin API (NPAPI), but only the newer Pepper plugin API (PPAPI).

  • What format is the sound file? Opera may not support WAV or MP3 playback - that depends on your system - but should support Ogg Vorbis.

  • What format is the sound file? Opera may not support WAV or MP3 playback - that depends on your system - but should support Ogg Vorbis.

    Thanks. I just tried to play sounds on social networks using their internal players and some multimedia websites, but all files there probably mp3. Video, i think mp4, not sure. Youtube though plays ok. I will find ogg to test.

  • tested ogg! OGG WORKS! MP3 does not!
    But video with vorbis does not :( Tried h264 mp4 video with vorbis audio

  • Installing VLC doesn't work either¿?

  • A solution that worked for me (with the same problem while watching a YouTube video) was to right mouse-click the top left hand corner of the tab. If the problem appears while you're watching a YouTube video (i.e. You get video but no sound) when you hover your mouse over the top left hand corner of your tab you'll see that the YouTube icon changes into muted speaker icon. Opera has a built-in feature that allows you to mute the audio playing in a tab by right mouse-clicking the top left hand corner of the tab. To unmute the audio just right mouse-click again. Problem solved. Good luck!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.