Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Fedora 20 and autokey-gtk when updating a Media-Wiki site.

  • While on Fedora 17, I used opera-12.16-1860.x86_64 from the official RPM download. It worked quite fine, making it (again) my favorite for 90%+ of my browsing activity (best speed, nicest rendering among other virtues, good job Opera!).

    However, my most frequent use is to update a MediaWiki based site. I rely heavily on autokey-gtk to insert chunks of text (e.g. Wikitext templates) by using shortcut abbreviations within the MediaWiki edit form. This worked nicely until I needed to update to Fedora 20. The Opera version hasn't changed, but this feature is now broken.

    It will start to insert gibberish as soon as I used one of my autokey sequences, and within the next few minutes Opera will become totally unresponsive - no crash report, it just freezes.

    Tried disabling extensions, changing compatibility to Opera 9.6, no effect - keeps freezing in that specific use. Other navigation, webmail, etc. just fine. Only my needed autokey interaction is broken...

    I tried another Wiki running with a more recent LAMP stack, with same results.

    Other 2 mainstream browsers are working just fine after the transition, receiving & expanding the autokey sequences w/o issues.

    What can be going on, is there a fix in sight ? I've seen a post of a user having a similar problem with just plain forms, but mine seems only related to auto-key. If I don't use it, the Wiki edit windows (and other forms) work fine.


  • Couldn't you put your templates into Notes in Opera and then insert them from the context menu?

    (As a KDE user, I have no idea about GTK-based software.)