[Solved]Max download messages prompt crashes Opera

  • I've just done a fresh install of Opera Mail, and I subscribed to several newsgroups. Each one asked how many messages I wanted, and I selected 1000 for each one. It got them all successfully, but now about once every 24 hours (I leave it running all the time), it gives me the same question for a random group (which I know it's up to date with anyway). No matter what I select, Opera crashes. Is there a way to manually change this setting so it doesn't ask in an ini file somewhere?

  • In the mail folder (see "Menu -> Help -> About Opera Mail" for the location), there will be an incomingN.txt file (where N is the number for the account as seen in accounts.ini). While Opera is closed, in that file, you can set the max_download. You can also set ask_for_max_download to 0 to turn it off. There's a "do not ask me again" checkbox for the latter though. It's at the bottom of the max download dialog that pops up.

    Also, if you have any issues with updating/fetching messages, you can modify last_updated. For example, I think you can just remove the last_updated line, save and start Opera Mail.

    If adjusting things doesn't fix the crash, close down Opera Mail and delete autosave.win in the sessions folder in the preferences folder. If that doesn't work, rename operaprefs.ini and start Opera Mail.

    If needed, you might have to delete the "mail" folder and start over.

  • I've changed the ask_for_max_download to 0, I'll see if that helps. I can't use the checkbox, as the crash makes it forget whatever I select.

    I only just reinstalled Opera freshly, as a system crash corrupted the mail folder. It shouldn't be messed up already!

  • This has fixed the problem, thanks.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.