Opera on SUSE (old version)

  • Hey Guys,

    I'm running a pretty old version of SUSE (11.2) and am attempting to install opera-stable_41.0.2353.69 on this box. It requires both "at" & "libnotify.so.4". I've installed both, however when I attempt to start Opera, I get the following error:

    opera: symbol lookup error: /usr/lib/libnotify.so.4: undefined symbol: g_variant_unref

    I have two questions:

    1. Is there a way to know what numeric version of a given dependency is required, when installing the .rpm version of opera? As an example, when installing, if it lists libnotify.so.4 as a dependency, what version of the libnotify4 do I need?
    2. Any ideas what's causing this error?

    Thank you!

  • Usually the RPM requirements should be specific enough ... I guess we'll have to wait until morning and see if one of the developers can comment.

    The underline character is reserved in Markdown; I'll edit your post by adding backslashes so that the underlines display properly (instead of making parts of the text italic as they do currently).

  • Thanks sgunhouse!

    Hopefully someone on here is able to assist!

    When I started doing some digging, is appears there many versions of the RPMs for both AT & libnotify4, tied to many versions of SUSE. I was just hoping to get some guidance on which one was the correct prerequisite for the Opera browser installation.

    Thank you!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.