Facebook gif and videos

  • I'm using Opera since it was born, but now I'm experiencing a pretty peculiar problem:

    When I click on a gif on facebook I see it just white, nothing moves, Ive to open it in another tab to see it, and when I click on videos on facebook I see just a blurred image and I can hear the sound of video. I note that I've installed the last version of Flash player and no extension at the moment.

    Any possible solution?

    Thx

  • Try clearing out your cache and cookies and such.

  • How to clean the cache?

  • Found, didn't work...

  • Version of Opera and Windows?

  • 41.0.2353.69 version, Windows 7 64bit

  • Can you play this video in Opera?

  • No, I hear only the sound

  • No, I hear only the sound

    Does opera://gpu shows anything unusual?

    Your Windows is a N version by chance?

  • mmm
    VPx decoding isn't supported before Windows 10 anniversary update.: 616318
    Disabled Features: accelerated_vpx_decode

    and

    Accelerated video decode has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: video_decode
    Accelerated rasterization has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: rasterization
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers
    Accelerated VPx video decode has been disabled, either via blacklist or the command line.
    Disabled Features: vpx_decode

  • ...and no, my windows is windows 7 64 bit ultimate service pack 1

  • OMG I was wrong, win correct version is Windows NT 6.1.7601 SP1... (ive too many pcs :D)

  • So what to do?

  • Accelerated video decode has been disabled

    It may be a problem.

    Do you see a GPU process in Opera's task manager?

  • How to check it?

  • Ok found, there is -> Gpu process: 104mb (morless)

    I just don't understand those " : " should be something written after it?

  • In opera://gpu/ do you see any error message in 'Log Messages'?

    Check opera://media-internals/ while trying to play a video to see if it gives you some clue on the problem.

    No, I hear only the sound

    Did you ever installed a codec pack? If not, can you play that video on Windows Media Player?

  • [1213/224926:ERROR:angle_platform_impl.cc(33)] : ANGLE Display::initialize error 5: DXGI 1.2 required to present to HWNDs owned by another process.
    [1213/224926:ERROR:gl_surface_egl.cc(612)] : eglInitialize D3D11 failed with error EGL_NOT_INITIALIZED, trying next display type
    [1213/233819:ERROR:angle_platform_impl.cc(33)] : ANGLE Display::initialize error 5: DXGI 1.2 required to present to HWNDs owned by another process.
    [1213/233819:ERROR:gl_surface_egl.cc(612)] : eglInitialize D3D11 failed with error EGL_NOT_INITIALIZED, trying next display type

    There are the log messages errors.

    I didn't install any codec.

    I can't play that video on Windows player, but i can play it on VLC. Anyway the codec problem could somehow be related to gif images too? Cuz i don't see them also.

  • I can't play that video on Windows player

    That's why you can't play it in Opera. Opera depends on the OS (Windows) to play (some) proprietary codecs, so if Windows can not play the video then Opera will also not be able to do it.

  • Opera://gpu shows as follow:

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Software only. Hardware acceleration disabled
    Video Encode: Hardware accelerated
    VPx Video Decode: Software only. Hardware acceleration disabled
    WebGL: Hardware accelerated
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    disable_direct_composition
    disable_discard_framebuffer
    disable_dxgi_zero_copy_video
    disable_framebuffer_cmaa
    exit_on_context_lost
    force_cube_complete
    scalarize_vec_and_mat_constructor_args
    texsubimage_faster_than_teximage
    use_current_program_after_successful_link
    Problems Detected
    VPx decoding isn't supported before Windows 10 anniversary update.: 616318
    Disabled Features: accelerated_vpx_decode
    Always call glUseProgram after a successful link to avoid a driver bug: 349137
    Applied Workarounds: use_current_program_after_successful_link
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage_faster_than_teximage
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Direct composition flashes black initially on Win <10: 588588
    Applied Workarounds: disable_direct_composition
    Zero copy DXGI video hangs on shutdown on Win < 8.1: 621190
    Applied Workarounds: disable_dxgi_zero_copy_video
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    Zero-copy NV12 video displays incorrect colors on NVIDIA drivers.: 635319
    Applied Workarounds: disable_dxgi_zero_copy_video
    Accelerated video decode has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: video_decode

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.