Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • In windows 10 magnet links doesn't work in 41/42. If i hit magnet link windows gives me only option to use windows store app. Firefox works.

    ps: i tried rewriting local date and editing reg hklm for protocol magnet.

  • Opera itself doesn't handle magnet links (it is not BT client anymore), but you should be able to install some BT client (qBittorrent is my favourite) and then clicking on magnet link launches BT software.

    If you have already done so, then reinstalling BT software should work.

  • There is no need to reinstall Tixati. It has option to associate link/protocol. It works with Firefox.
    Edge and Opera are ignoring magnet links.

  • There is no need to reinstall Tixati. It has option to associate link/protocol. It works with Firefox.
    Edge and Opera are ignoring magnet links.

    Magnet links work fine for me in Opera when using qBittorrent maybe you need to change you BT software if Tixati isn't picking up magnet clicks from your browser

  • There is no need to reinstall Tixati. It has option to associate link/protocol. It works with Firefox.
    Edge and Opera are ignoring magnet links.

    It might be a registry issue then where Tixati doesn't create the necessary registry key. For Firefox, maybe it goes out its way and uses a different method to find the handler.

    Or, maybe the associate function in Tixati just applies a certain setting in the registry, but doesn't write the correct path like reinstalling does.

  • In registry, what you see on next location?


    There must be your Tixati launching command, like mine for qBittorrent, with different executable and different path:

    "C:\Program Files (x86)\qBittorrent\qbittorrent.exe" "%1"

    If yours doesn't point to Tixati or has some quotes missing, write down or export current value (for backup) and write in value, corresponding to your system. Relaunch Opera - does it behave better?

  • Yeap. Full path and tixati exe with param.

    Windows Registry Editor Version 5.00

    "URL Protocol"=""
    @="URL:torrent magnet link"
    "Content Type"="application/x-magnet"

    @=""C:\Program Files\tixati\tixati.exe",1"



    @=""C:\Program Files\tixati\tixati.exe" "%1""

  • Wonder if the server sends the magnet links as application/x-bittorrent instead and Opera looks up that in the registry.

    But, either way, you'll want to make sure the Magnet protocol is defined in the registry. For uTorrent for example, in



    "C:\Users\mike\AppData\Roaming\uTorrent\uTorrent.exe" "%1" /SHELLASSOC

    Same thing in:


    (which I see you have one).

    Content-Type is application/x-magnet for me too.

    I also have a


    that has a content-type of application/x-bittorrent

    Might want to see if tixati has one.

    Also look in


    to see if there's a tixati.exe subkey. I think that's needed for tixati to show up in default programs.

    That has a shell -> open -> command structure too.

    You shouldn't need anything in HKEY_LOCAL_MACHINE.

    I'll try with tixati later to what I can find.

  • I just installed 64-bit tixati on Windows 10 and clicked on a magnet link in Opera 43.0.2412.0 64-bit. Opera asked if I wanted to allow it and I did. Then, it loaded up tixati. But, nothing happened once tixati loaded up. Same behavior in Firefox. That might have something to do with the link itself, but it does get passed to tixati like it's supposed to.

    I checked. tixati does a key at


    along with




    I see


    which are referenced by


    There's also:


    So, I would reinstall tixati just for good measure. You might even want to remove any of its registry keys after the uninstallation before reinstalling.

    If that doesn't help, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "Standalone Installation (USB)" and install. Try magnet links in that Opera. If they work there, it means it's something messed up with your Opera profile (mabye Local State file or preferences file).

    I didn't try in Opera 41/42. So, if it's a bug, maybe it's just fixed in 43.