Opera not letting Macbook Sleep

  • Have noticed over last couple of days since latest update that my MacBook Pro will not go to sleep anymore.
    I have Energy Saver to sleep the screen in 3 minutes, but there is no sleep had.
    When I check Activity Monitor under "Preventing Sleep" everything open is "No" except for Opera, which is "Yes". When I check the list under Opera, there is nothing with a "Yes" by it, so I am stumped.

    Has anyone else had this issue and found a fix?

    Thank you!

  • Do you have any sites with Flash running? I wonder if Flash can cause this. You can try if this is the cause by disabling Flash completely using Opera -> Preferences... -> Websites (on the left) -> Flash, select "Block sites from running Flash".

  • Or, do you have any running downloads or paused downloads? Opera explicitly prevents sleeping while it's downloading something.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.