[Solved]Opera is not playing mp3's

  • continued from Opera for Windows: this thread

    Opera 41.0.2353.56 on Debian Testing, amd64

    Opera does not play mp3 files, while AFAIK, it should. Instead, Opera asks where to download the file instead of playing it:

    ogg example

    mp3 example

    The ogg plays, the mp3 is greyed out. When I click a direct link to an mp3, opera asks where to download the file:

    direct mp3

    OTOH, there is a site http://odb.org/ on which there is an mp3 which is played by Opera (not by flash) and AFAICS this site uses the same audio settings as the examples above.

    The OS plays all types of audio formats, VLC, mplayer, FireFox, no problem. Anyone a hint why ogg is playing and mp3 is not?

    Richard.

  • What mechanisme does Opera use to recognize mime types?

    R.

  • What version of libffmpeg does your system have?

  • There is the libffmpeg.so that comes with Opera:

    $ ls -al /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so
    -rw-r--r-- 1 root root 1280528 Nov 7 12:44 /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so

    There is a libffmpeg that comes with qmmp, but installing that package does not make any difference. I checked the file:

    /usr/lib/x86_64-linux-gnu/opera/resources/ffmpeg_preload_config.json

    and the path to that particular Opera lib wasn't there. I added it, restarted Opera, but still no mp3...

    I threw away the ~/.config/opera/ dir, but no difference. It seems that I'm the only one with this particular problem. I have no standard config, I'd like to keep my system simple, but OTOH Firefox, VLC, mplayer etc work fine.

    R.

  • I had the same problem on openSuse with mp3 and H264 codecs. You can test the codec support at http://html5test.com
    I solved it by replacing libffmpeg.so in the opera directory with the one from the chromium installation. At openSuse the directories are /usr/lib64/chromium and /usr/lib64/opera. HTH.

  • Thnx, this was the solution. I installed a package called chromium-codecs-ffmpeg-extra which I was able to find at the ubuntu packages site.

    OTOH the question remains why the libffmpeg.so that comes with Opera doesn't work. The two libffmpeg.so files are mentioned in /usr/lib/x86_64-linux-gnu/opera/resources/ffmpeg_preload_config.json and the Opera native one does not support aac and mp3 according to http://html5test.com.

    Quite strange IMHO, as nobody seems to encounter this particular problem...

    Richard.

  • BTW, I just found this at the Opera site. AFAIUI mp3 and aac is not supported natively by Opera. Question remains why nobody complains.

    Richard.

  • Is there a way to change the subject of the thread? I'd like to add [SOLVED]

    Richard.

  • Seems that opera relies heavily on chromium-codecs-ffmpeg-extra which gets installed on Ubuntu/Mint together with proprietary codecs. So this problem is non-existent on Ubuntu/Mint. Most people use these distributions. Chromium/Firefox/Vivaldi don't suffer from this problem, obviously it's an Opera issue.

  • Yes, and it would be nice if Opera would give a clear error message like "codec not supported" and a link to a FAQ or a solution. Not just a greyed out audio bar...

    I miss the good old newsserver btw. Pity that they switched the thing off.

    Anyway, it works fine now. Thnx for your answer!

    Richard.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.