Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Long launch times (26sec) for Opera on 64bit XFCE/archlinux

  • Not sure what's happening, and not sure how to debug... .. .

    Version information

    Version: 41.0.2353.56 - Opera is up to date
    Update stream: Stable
    System: Arch Linux (x86_64; XFCE)
    Browser identification

    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.87 Safari/537.36 OPR/41.0.2353.56

    Paths

    Install: /usr/lib/opera
    Profile: /home/ljohnson/.config/opera
    Cache: /home/ljohnson/.cache/opera

  • Sync enabled? Extensions?

  • Sync enabled? Extensions?

    No extensions installed.

    No synchronization.

    Ad blocker turned off.

    No shortcuts.

    Opens with prior tabs.

    A reasonably plain jane installation.

  • I tried the developer version and no improvement - opera-developer 43.0.2403.0-1

    When I open opera from the terminal, I get this:

    [--ljohnson{12:05:04}~]$ opera
    
    (opera:5966): libnotify-WARNING **: Failed to connect to proxy
    

    or this

    (opera:6207): libnotify-WARNING **: Failed to connect to proxy
  • Disable Hardware Acceleration.

  • Hardware acceleration disabled, no change in launch time.

  • How many bookmarks do you have? I'm going to presume this is not some really slow processor with tiny amounts of RAM - as Opera 4x is based on Chromium it does not run well in < 2GB RAM.

  • No bookmarks (are you kidding? who would use bookmarks in a browser that takes 26 seconds to open)

    Chromium and Chrome and Foxfire and Vivaldi all launch in less than three seconds.

    Cpu speed from cpuinfo 3409.00Mhz
    cpuinfo might be wrong if cpufreq is enabled. To guess correctly try estimating via tsc
    Linux's inbuilt cpu_khz code emulated now
    True Frequency (without accounting Turbo) 3410 MHz
    CPU Multiplier 34x || Bus clock frequency (BCLK) 100.29 MHz
    
    Socket [0] - [physical cores=4, logical cores=8, max online cores ever=4]
      TURBO ENABLED on 4 Cores, Hyper Threading ON
    
      Max Frequency without considering Turbo 3510.29 MHz (100.29 x [35])
    
      Max TURBO Multiplier (if Enabled) with 1/2/3/4 Cores is  38x/37x/36x/35x
    
      Real Current Frequency 2157.34 MHz [100.29 x 21.51] (Max of below)
    
            Core [core-id]  :Actual Freq (Mult.)      C0%   Halt(C1)%  C3 %   C6 %  Temp      VCore
    
            Core 1 [0]:       2124.32 (21.18x)      16.1    31.2    7.69    51.1    33      1.0258
    
            Core 2 [1]:       2157.34 (21.51x)      14.1    30.4    6.92    53.8    32      1.0258
    
            Core 3 [2]:       2014.27 (20.08x)      6.61    15.6    4.18    76.3    36      1.0258
    
            Core 4 [3]:       2069.80 (20.64x)      4.81    17.3    1.16    78.6    34      1.0258
    
    
    vmstat
    
    procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
    
     r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
    
     0  0      0 9896016 172504 2071932    0    0    48    18  792  822 13  2 85  0  0
    

    htop screen grab @ https://drive.google.com/open?id=0B2Z1PtrPT-greWhEdERlVkJGYTQ

  • R.I.P. Opera 41

  • I have the same issue

    [fethi@c_corax ~]$ opera --debug
    
    (opera:1802): libnotify-WARNING **: Failed to connect to proxy
    ** Message: Remote error from secret service: org.freedesktop.Secret.Error.IsLocked: Cannot create an item in a locked collection
    ** Message: Remote error from secret service: org.freedesktop.Secret.Error.IsLocked: Cannot create an item in a locked collection
    [fethi@c_corax ~]$ [1223/195325:ERROR:native_backend_gnome_x.cc(523)] Keyring find failed: 
    [1223/195348:ERROR:object_proxy.cc(583)] Failed to call method: org.freedesktop.NetworkManager.GetDevices: object_path= /org/freedesktop/NetworkManager: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.NetworkManager.service not found.
    

    using Opera 42.0 on 64bit XFCE/archlinux

  • libnotify-WARNING **: Failed to connect to proxy

    Means that opera could not connect to a notification server. Either because there is no notification server or it is not launched.
    https://wiki.archlinux.org/index.php/Desktop_notifications
    In my case there was no notification server. Instaling one helped, opera finaly is starting normally.

    I know the thread is old but maybe it will help someone in the future.

Locked