MAC OSX 10.6.8 32-BIT

  • For all the users who have snow leopard 32bit (they cannot update their o.s to a newer version!).
    The last Opera we can use is v. 25.0.1614.71 I'm not the only! Why Mac users cannot have new features and on windows xp (that is older) can use Opera v.36 ?? Who has mac 10.7 can install osx till almost 2016, who has 10.6.8 needs a new computer, or they switch to lastest possible supported Firefox 48 (augustus 2016).
    We don't ask the complete support but just a few version every year..

  • Sorry, this is just not possible: maintaining an old version costs time (and money), and while there are many, many computer users still using Windows XP, which is why Opera decided to keep a version with security updates available for those users, there are very few on OS X 10.6.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.