Opera 12.18 mail problem

  • Laptop using 12.18 for mail & Win 10 (I browse with Opera 40.xx).

    I can receive mail with 2 different accounts but can't send mail with those accounts. These 2 accounts are using 1and1 servers, specifically smtp.1and1.com to send. Weird that I can send at home and every other place I use wireless at (Dozens).

    I'm still at the casino where this is happening. Here's info: http://postimg.org/image/92e6esaxf/

    I can send email with my Gmail and Yahoo accounts here.

    Anything I can try on this end while I'm here?

  • Well I fixed that! LOL

    In the settings I unchecked "Secure Connection (TLS)"

    Can someone explain why that worked?

  • Opera 12.18 is old. The version of TLS it uses is out of date.

  • What port were you using for smtp.1and1.com? You should use port 465 with TLS checked (although you can use 587 with TLS checked too, but try 465 if you haven't yet). But, in preferences in Opera under "advanced -> security -> security protocols", make sure tls 1, 1.1 and 1.2 are all checked.

    If you keep TLS unchecked, your username and password will be sent to the server unencrypted, so try everything you can with TLS checked first before giving up.

    Try temporarily disabling your email scanner if your anti-virus has one to see if that helps with TLS working.

    I used to use smtp.1and1.com with Opera 12.18 and it worked fine. I don't know if 1and1 changed anything recently though.

  • Well here's an interesting development. Staying at an Econo Lodge tonight and it sends emails just fine with my 1and1 accounts!

    Burnout426. Any explanation why it works here but not there?

    Outgoing port 25! Port 143 for incoming. Only TLS1 is checked in advanced->security->protocols.

    It seems this happened somewhere else a couple of years ago and I just waited till I got home to send my emails and then I just forgot about it.

  • Any explanation why it works here but not there?

    I would guess it depends on the wifi and gateway you're connected to. Perhaps the one doesn't allow encrypted traffic(TLS). Or, it does allow encrypted traffic, but you need to accept a certificate so they can snoop your traffic before it goes out.

    With port 25 specifically though, that port is often blocked now by ISPs and such as the port gets abused by spammers. It often requires no authenticate to send out and is unecrypted. Some ISPs allow it *if* you're sending to an address on the same ISP. It all depends though.

    Sometimes you have to use port 25 or at least have TLS disabled for your email scanner to scan your email for viruses. The anti-virus then encrypts the connection on the way out. Others email scanners might require a certificate.

    In short though, unless absolutely necessary, you should be using the following on the Servers tab in the account's properties:

    imap.1and1.com
    port: 993 
    TLS: checked 
    
    smtp.1and1.com 
    port: 465 
    TLS: checked 
    

    And, in Opera's preferences, you should enable TLS 1.1 and 1.2 unless it causes problems.

    Then, for any anti-virus, if possible, configure it so you can still use those settings.

    If you use port 143 with TLS unchecked, your connection won't be encrypted. Same with port 25 (or 587) with TLS unchecked.

    Some places that you connect require you to open your browser and accept/login to their gateway before internet and such will work.

  • Thank you very much burnout for the detailed explanations. I will make those changes to my ports, etc.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.