Problems with videos on youtube

  • Hey, I really want to use this browser as my daily, but I just can't stand the issues with youtube players. Some videos play ok, but some doesn't, I was searching for solution to this problem, but I can't find. Can you please help me?

  • Same here - installed Opera today, as I have done from time to time over the past ten years, only to find that NO YouTube vids will play. Love the VPN Opera now has, but this is a major flaw. Seems there's always something that keeps Opera from being my browser of choice.

  • Hi, what version of OS X are you using? No videos work? What's the error message?

  • In my case: newest stable opera, newest El Capitan
    error like that: http://imgur.com/aqcUUwy
    It's happening for a long time in v40, since Opera Developer (that's reason why I had stopped using it, thought final release will fix it).

    EDIT: And console: http://imgur.com/H0b9XpT

  • Could you give me an example of a video that does not work?

  • Here's the Opera Twitter account, viewed in Opera: http://imgur.com/a/2SkvW

    El Capitan 10.11.5
    Opera 40.0.2308.62

  • Hey, sorry for late response. I'm currently using Mac OS Sierra, but on the previous version was the same issue, so I don't think the problem is in the system version.

  • Here's a Youtube video that my Opera browser can't play: http://imgur.com/a/ZpqV1

  • Here's mine example: https://youtu.be/pFt6rRFSwJM

  • Update to 40.0.2308.62 didn't solve it.

  • Same here - installed Opera today, as I have done from time to time over the past ten years, only to find that NO YouTube vids will play. Love the VPN Opera now has, but this is a major flaw. Seems there's always something that keeps Opera from being my browser of choice.

    I share what you like about Opera. Your experience with videos is similar to what I am experiencing in Twitter. This problem is keeping me from going to Opera full-time.

  • The ones I flagged are working now, as is bartilan's. Still no videos work on Twitter, including the ones posted by @Opera! ("This browser does not support video playback" LOL).

    The place to report bugs (desktop): https://bugs.opera.com/wizard/desktop

  • I opened every one of those YouTube links and was able to watch each video (I'm using the latest version of Opera on macOS Sierra).

    The trick is to first download the video to your hard drive and watch it there. If I tried to play those videos listed above inside the browser I got the same errors you all were seeing. But if I downloaded the video first, it played just fine.

    If you install the "Video Downloader All In One" extension (http://addoncrop.com/video_downloader_all_in_one/), then go to the YouTube video page, an additional green Download button will appear just below it. Click it, and it will download it to your hard drive and it will play just fine.

    Hope this helps!

    Dan

  • Any tip on making youtube really fullscreen?
    It's not working neither on Twitch nor YT.

    Thank you.

  • nostromo1965 thanks for the tip. However, the point remains that the browser is broken if it can't play videos.

  • i had issues with my opera browser on my mac. but i just fixed them simply by opening opera://gpu then at the very top "Graphics Feature Status" i used to have "Rasterization" and "Video Decode" in "Software only. Hardware acceleration disabled" mode, which caused many problems with Youtube html5 player as well as several other problems.

    The solution is to go to opera://flags and in search bar type the specific category of "Graphics Feature Status" (in my case "Rasterization" for example). Since this is to do with GPU, i enabled "GPU rasterization" and right away under "Graphics Feature Status" , in opera://gpu, next to "Rasterization" appeared a green "Hardware accelerated" sign.

    I did the same with "Video Encode". Literally the same and now i DON'T have to wait couple of hours to see an uploaded video in Youtube in html5, I can watch Youtube streams (also html5). I am not so much into twitter or vine, but i think this fixed ALL my video playback issues in opera. You are Welcome.

  • i had issues with my opera browser on my mac. but i just fixed them simply by opening <opera://gpu> then at the very top "Graphics Feature Status" i used to have "Rasterization" and "Video Decode" in "Software only. Hardware acceleration disabled" mode, which caused many problems with Youtube html5 player as well as several other problems.
    The solution is to go to <opera://flags> and in search bar type the specific category of "Graphics Feature Status" (in my case "Rasterization" for example). Since this is to do with GPU, i enabled "GPU rasterization" and right away under "Graphics Feature Status" , in <opera://gpu>, next to "Rasterization" appeared a green "Hardware accelerated" sign.
    I did the same with "Video Encode". Literally the same and now i DON'T have to wait couple of hours to see an uploaded video in Youtube in html5, I can watch Youtube streams (also html5). I am not so much into twitter or vine, but i think this fixed ALL my video playback issues in opera. You are Welcome.

    I tried your suggestion but still doesn't work.

    Here a link to test.
    https://gaming.youtube.com/watch?v=q3kS0oILtjc

    Every 3 videos that I tried at least one have this problem.

  • I also recently stopped being able to open youtube videos with opera...

  • Hi all, whether you can see these videos or not depends on the graphics adapter used in your Mac (this is why some people can see the videos and others can't, using the same version of Opera and the same version of macOS).

    On Macs that have graphics cards that can't be used for hardware-accelerated video decoding by Opera, Opera's stable version currently doesn't support playing back MSE/DASH videos ( https://en.wikipedia.org/wiki/Dynamic_Adaptive_Streaming_over_HTTP ). These videos are used on Twitter, and in many cases on YouTube (especially for streaming videos).

    The current developer edition of Opera (where we test experimental features and new stuff) includes a software video decoder for these cases. If you have this problem, please download Opera Developer from http://www.opera.com/blogs/desktop/ and let us know if this works for you. This feature will become available in Opera's stable version after testing and when we're sure it works as expected.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.