Opera inserts single zero-width white space character when focusing on text inputs/textareas.

  • Bug

    Starting about 2 weeks ago, Opera began inserting some unknown zero-width white space character at the cursor when I focused on an input or textarea.
    When focusing, after about half a second, a narrow underscore will appear, until I delete it, or move my cursor, at which point it collapses to nothing (but remains in the string), and becomes impossible to find and remove, although if you know where it is, you can delete it with backspace or delete.
    This occurs with any sort of focus, whether it's tab-based, clicking, returning to a page, or having a page autofocus.
    It appears in the search/location bar as well, but appears to get stripped out pretty quickly (some other sites strip it as well), but you still see a flicker.
    When I accidentally submitted a form with the character, it showed up on the site as a diamond with a question mark inside of it.
    Updating today did not fix the issue.
    Initially, I thought it was a hardware or OS issue, but this is not happening in any program or browser besides Opera.
    I'll try to add the character here: ""

    Version Information:

    Version: 39.0.2256.71 - Opera is up to date
    Update stream: Stable
    System: Mac OS X 10.10.5 64-bit

    Browser identification:

    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 OPR/39.0.2256.71

    Additional Information:

    I do use a Dvorak layout, but the keyboard hardware is the same. Using the US layout does not seem to fix the problem.

  • There was a similar issue on OS X 10.10 when dictation was on in Preferences. Can you check if it's a case for you also?

  • Disabling Dictation & Speech in System Preferences fixed it for me. Thank you so much, that was driving me nuts!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.