This browser does not support video playback

  • Hi there,

    I keep getting this message on twitter

    "This browser does not support video playback"

    Opera beta 40.0.2308.11
    MAC Pro Yosemite 10.10.5

    Any help would be great

  • Could you send me an example of this video? I'm not able to reproduce your issue on my machine.

  • Hello there,

    Thank you for your reply

    Im not sure how I would link tweets safely here, but here you can see some screen shots I have taken from my feed.

    This image is the error I'm getting, if I click the tweet I see the play icon for a second then shortly after I get the "This browser does not support video playback" error and cannot play the video.
    https://i.imgsafe.org/49d81dbcd7.png

    Its not all videos though as seen bellow this video works fine
    https://i.imgsafe.org/49d972115b.png

    Thanks

  • This is my example:
    MACBOOK OSx El Capitan V. 10.11.6
    html5: Video not properly encoded
    http://pad.mymovies.it/filmclub/2016/02/148/trailer2.mp4
    Thanks

  • Here is another example from Opera's very own tweets, that don't open on its own web browser.

    https://i.imgsafe.org/c4734169dc.png

    Anyone know whats up here.

    Oh BTW @claudioop that video plays fine on my system.

    Thanks

  • You can view many of the "This browser does not support video playback" errors at https://twitter.com/funnyordie

  • This issue is being analysed in our database: https://bugs.opera.com/browse/DNA-37874

  • For more details, if this happens to you, you're not alone: it depends on which GPU (graphics card) your Mac has. This issue generally occurs with older Macs, since it depends on whether the GPU is able to decode video with hardware acceleration.

    Opera is currently only able to decode MSE/DASH videos when there is hardware acceleration available. At the time we thought this would only impact a small and shrinking group of users (those with older Macs). As MSE/DASH has become more popular (used widely on Twitter, and on Youtube especially for streaming videos) we see more machines than we thought are impacted by this.

    It would help if you can all list which Mac you have. You can see this in  → "About Your Mac". The first line is in general enough for us. For example, on my machine, which doesn't have this problem, it says "MacBook Pro (Retina, 15-inch, Late 2013)".

  • MacBook Pro (17-inch, Late 2011)

  • MacBook Air (13-inch, Mid 2011)

  • i had issues with my opera browser on my mac. but i just fixed them simply by opening opera://gpu then at the very top "Graphics Feature Status" i used to have "Rasterization" and "Video Decode" in "Software only. Hardware acceleration disabled" mode, which caused many problems with Youtube html5 player as well as several other problems.

    The solution is to go to opera://flags and in search bar type the specific category of "Graphics Feature Status" (in my case "Rasterization" for example). Since this is to do with GPU, i enabled "GPU rasterization" and right away under "Graphics Feature Status" , in opera://gpu, next to "Rasterization" appeared a green "Hardware accelerated" sign.

    I did the same with "Video Encode". Literally the same and now i DON'T have to wait couple of hours to see an uploaded video in Youtube in html5, I can watch Youtube streams (also html5). I am not so much into twitter or vine, but i think this fixed ALL my video playback issues in opera. You are Welcome.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.