Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hello, does someone of you experience this problem?

    Because I have it, and dont know what to do about it... I have tryed clean install with profile folder removed (no extensions, nothing), but it didnt help. I dont have this problem in firefox...

    And when I open some webpage in opera (it will start loading) then I will swith to firefox and open the same website, it will finish loading in firefox, then i switch back to opera, and opera is still hanging on speed dial and still loading webpage... So, whats going on?

    Im really considering returning to firefox, because this slowness is terrible. And Im not talking about many other things...

    • latest stable opera 32, Win 10 x64
  • Do you have Opera Turbo enabled? Do you have any proxy settings configured in Internet Options inside the control panel?

  • No, Im not using opera turbo and did not configure anything in internet options from the time i have installed windows.
    My internet speed is also ok 10 MB/s. But I think, that this shouldnt be a problem when firefox is running ok.
    There must be something wrong with opera.
    Also, my hardware acceleration in opera is enabled, because scrolling is more smooth when its enabled. I will try dev version.

  • Ok, fresh install of dev version, and its the same... Default settings, nothing edited, click on youtube tile, loading like 10 sec, and then it will show up youtube webpage. Opening new tab (this is fast) middle click on youtube, and again, loading 10 secs +-.
    Also, Alt+P is loading like that too.

  • I saw your note also on the Opera blog. May I ask you please to:

    • go to opera:plugins
    • disable each plugin one by one and see what happens

    Please do this in Opera developer first. If there's a plugin problem, we will know soon. If something else, we will continue investigation.

    And sorry for bothering you, but I'm unable to reproduce it and need details to try to help you (and possibly other users who might experience the same issue). Indeed your machine is not of the newest range, but anyway it shouldn't be like that.

  • Yes, thank you that you are investigating this issue. I have again tried clean install of dev version, went to opera://plugins and disabled plugins there, but no change. I really think it must be somehow hardware related, cause its happening when I have some applications running in the background, like steam, skype, media player etc. But its still not affecting firefox.

    I should also mention, that I dont have SSD disk, and if I want to summarize it, its like this:
    This is ok and fast:

    • Opening links from webpage, in curent tab.

    This is slow:

    • Opening links from Speed dial in current/background/foreground tab.
    • Opening links from webpage in background/foreground tab.
    • Opening any opera page (settings, history, etc)

    I would be glad if you can somehow reproduce it and fix it.

  • Ok, its as I said. I had there like 4 applications running in the background, and everytime I closed one, opera was little bit faster. If I dont have any other application in the background, the webpage from speed dial is starting to open like in 2 secs after i clicked it. (I mean by this, that there is still "Speed dial" and loading circle in the title, but after 2 secs, the webpage title will show up and it starts to load web content).

  • @stanislavstratil
    One possible culprit to you problem could be your firewall or Anti-virus program (
    I know it sounds stupid, but if you have any of them enabled, try to disable for a moment a see is it helps (maybe also disconnect from the net if you worried about privacy/security)
    Firewalls (like ZoneAlarm, I personally had problem like your with it) have some option for system files that you can disable (I don't remember anymore what was it)

  • Im using only basic Windows Defender and Windows Firewall... However I did try to disable them, but it didnt help. Anyway, thx for tip.

  • ok, sry it didn't helped

  • Eh, I'm sorry I could not help either 😞 I'll try to perform checks on throttled OS, but so far I'm out of other ideas.

  • Nevermind, thank you all... I was forced to downgrade to Windows 7 64bit, because of hardware problems with soundcard, and Opera is running fine now.