Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 31 youtube. I want to watch all videos in html5.

  • @avl: Okay, then I understand. Thank you for the information.

  • I appear to have had the same problem. This may not be the best solution, but I've found this to work so far:

    • Install chromium-ffmpeg-codecs-extra (which is currently version 44 as at 2015-08-27)
    • Maybe back up /usr/lib/x86_64-linux-gnu/opera/lib/libffmpeg.so.31
    • Have permission to write /usr/lib/x86_64-linux-gnu/opera/lib/ and contents (helps to be root or have sudo)
    • Symlink /usr/lib/chromium-browser/libs/libffmpeg.so to /usr/lib/x86_64-linux-gnu/opera/lib/libffmpeg.so.31

    YMMV, but that's worked for me, for now!

  • Install chromium-ffmpeg-codecs-extra (which is currently version 44 as at 2015-08-27)
    Maybe back up /usr/lib/x86_64-linux-gnu/opera/lib/libffmpeg.so.31
    Have permission to write /usr/lib/x86_64-linux-gnu/opera/lib/ and contents (helps to be root or have sudo)
    Symlink /usr/lib/chromium-browser/libs/libffmpeg.so to /usr/lib/x86_64-linux-gnu/opera/lib/libffmpeg.so.31

    @crosph, your solution can be refined: instead of writing to lib, write the file to /usr/lib/x86_64-linux-gnu/opera/lib_extra/libffmpeg.so.31 (you might have to create the lib_extra directory). Opera recognizes the lib_extra directory specifically for this purpose (so that you can put a custom version of ffmpeg in there). Then you don't have to overwrite any files, and it won't get lost whenever you update Opera (although you'll have to do something when a new version gets released).

  • To opera devs:

    Why don't you just unbundle ffmpeg and use the system-default one?

    Largely most people have already installed a "competent" ffmpeg library anyway...

  • BTW - For Fedora users: The "Russian Fedora" Repos has it all nicely packaged. Including the ffmpeg libs.

  • @crosph:

    I can't apt-get chromium-ffmpeg-codecs-extra, but I can get chromium-codecs-ffmpeg-extra (codecs before ffmpeg). Did you write the package name wrong, or is this different on different versions of Ubuntu? Or are you not on Ubuntu?

  • To opera devs:
    Why don't you just unbundle ffmpeg and use the system-default one?
    Largely most people have already installed a "competent" ffmpeg library anyway...

    This is what we did before. We have two problems with this approach now:

    • Chrome is integrating ffmpeg more closely, meaning it's harder to just 'unbundle' ffmpeg (the bundled ffmpeg has been changed, and the video implementation relies on some of their customizations)
    • ffmpeg has a very unstable ABI, meaning it's very hard to say what 'system-default' is. If we compile to work with one specific version, Opera will crash when it's used with other versions of ffmpeg, and not all distributions (or different versions of distributions) have the exact same versions of the ffmpeg libraries

    So the problem is that there's no "just" in "just unbundling" and no "competent" in "competent ffmpeg library" 😃 We're evaluating our options, we know that the current solution is far from ideal for everyone involved.

  • Is there a way I can tell Youtube that I can't play H.264 (https://www.youtube.com/html5)?

    This way it would fall back to playable formats instead of launching the flashplayer, and so I should be able to use a feature such as playback speed not supported in the flashplayer.

  • For the time being, on Debian testing, I am using:

    Which seems to work for any html5 video at the moment.

    Regards,
    Allan

  • @metalys

    For the time being, on Debian testing, I am using:

    Put it in /usr/lib/x86_64-linux-gnu/opera-beta/lib_extra instead (create the directory if it's not there). That way it won't get removed on updates. Opera will read lib_extra before reading lib.

  • @avl

    Put it in /usr/lib/x86_64-linux-gnu/opera-beta/lib_extra instead (create the directory if it's not there). That way it won't get removed on updates. Opera will read lib_extra before reading lib.

    Ah, excellent. (And I'm sorry I didn't read through the thread so you could avoid repeating yourself..) 🙂

  • I hope let me play some funny videos on youtube. libffmpg there is not present in Ubuntu 14.04, hope that this fix works is borring looking for some content and need to star another browser because you cant see media on this.

  • @metalys

    For the time being, on Debian testing, I am using:

    Put it in /usr/lib/x86_64-linux-gnu/opera-beta/lib_extra instead (create the directory if it's not there). That way it won't get removed on updates. Opera will read lib_extra before reading lib.

    Can you put that lib in Opera deb file?

  • Developers are f**king mad. I'll return to Firefox.

  • I did this:
    ln /usr/lib/chromium-browser/libs/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/lib_extra/libffmpeg.so.31
    And it worked in 31 but stopped after update to 32.

    Edit: looks like you need to change filename to libffmpeg.so.32

  • If anyone wants to copy-paste the above command, the forum ate underscores, it should be:

    sudo ln /usr/lib/chromium-browser/libs/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/lib_extra/libffmpeg.so.32
  • Currently I cannot play video from Twitter, Twitter show "This browser does not support playback video". And this test page (http://www.quirksmode.org/html5/tests/video.html) I also cannot play H.264/MP4

    I can play video on web normal with other browsers as Edge, Firefox and Chrome.

    I am using Windows 10 Pro x64 with Opera 32

    Please help me workaround

  • Doesn't work for:

    Opera Developer 39.0.2248.0

    Ubuntu 16.04 LTS (x86_64; LXDE) (64-bit)

    chromium-codecs-ffmpeg-extra_50.0.2661.102-0ubuntu0.16.04.1.1237_amd64

    sudo ln -s /usr/lib/chromium-browser/libs/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera-developer/lib_extra/libffmpeg.so.39
  • Hi @oshilan, try to follow the below steps, and see if this helps in your case:

    1. Navigate to the Opera's installation folder (find the path in Opera's menu > About Opera), and create a new folder "lib_extra",

    2. Download the "opera-developer-ffmpeg-codecs-52.0.2735.0" package, and extract the "libffmpeg.so" file to this folder.

    For anyone else, who's having the same problem on the 32-bit Linux distribution, you can download the appropriate package from here, and follow the above steps.

  • @l33t4opera

    It works. Thanks!

Log in to reply