Do you have opera vpn and/or opera turbo enabled?