Try IMAP, set the port to 993, check TLS and set "authentication" to "auto".

Make sure the name of the mail server is right. It might not be and might be or something like that.

For your username, it might have to be your email address with the @... part. Or, you might have to omit the @... part.

You can log the connection and see what the error is.

You might also want to research on the net what the server settings should be for a godaddy site. And, maybe there's something in your website's control panel that you have to mess with to enable IMAP.

Also, try with Thunderbird. If you can get it working there, then just look at what server name it uses in the account's properties and use that in Opera.

Each time you mess with a different servername, delete the IMAP account in Opera and add it back in just for good measure.