Even though you already resinstalled, install one more time. Download the setup file (x64 one if you have 64-bit Windows) in ftp://ftp.opera.com/pub/opera/desktop/51.0.2830.40/win/, launch it, click "options", make sure the install path is "C:\Program Files\Opera", check "Make Opera Default Browser", make sure "Install for" is set to "All Users", adjust your bookmark import options as you want and choose install (or upgrade). Then try setting Opera as the default browser in Default Apps/Programs in Window's settings.