In the properties of the Opera shortcut, change the command to Opera.exe For example: "C:\Program Files (x86)\Opera\launcher.exe" --allow-outdated-plugins It's what you're supposed to do in Chrome. It should work with Opera, but not sure if it actually will. Just note that if it works, it'll affect all plug-ins. So, make sure you're up to date with your other plug-ins. You might even want to launch the Opera installer, click "options", set "install path" to a folder in your userprofile area, set "install for" to "Standalone Installation (USB)" and install. Then, create a shortcut for that Opera that passes --allow-outdated-plugins and only use that Opera for that site. But, Opera not showing an "allow" option like Chrome does sounds like a bug.