(1) change .deb metadata to depend on libgbm1 >= 8.1~0 [like .rpm]
(2) Linux .deb downloader sends 68.0.3618.5, despite ...18 being shown here
I am unable to install opera-beta 68.0.3618.5 (nor opera-developer 69.0.3623.0) on my Linuxmint 17.3 system. (Not beta 68.0.3618.18, because the server sends 68.0.3618.5; not developer 69.0.3630.0, because this version wasn't built for Linux).
Installation fails due to a new package dependency on 'libgbm1 (>= 17.1.0~rc2)'. Previous Opera versions I installed (opera-beta 67.0.3575.28, opera-developer 68.0.3590.0, and all 357 versions I have .debs of, as far back as opera-beta 43.0.2442.21) did not call for libgbm1 at all.
My system has libgbm1 10.1.3-0ubuntu0.6. I converted the RPM build of 68.0.3618.5 to DEB with
alien, and the converted package only calls for 'libgbm1 (>= 8.1~0)', well within the range of my system.
Also worth noting: Google chrome-beta 81.0.4044.69 and chrome-unstable 82.0.4085.12 install happily. These are respectively newer than the base versions used in the current Opera beta & developer packages.
Yes, the system's grossly out of date. But earlier releases installed fine; this is caused by an unnecessary change in your build environment. Your RPM build environment says only 8.1~0 is required; please change the DEB packaging manifest to the same.
I did not install the RPM as I do not wish to step outside the system's package manager and establish a permanent exception I would have to maintain.