It installs and works fine for me on Windows 10 64-bit OS Version 1909 (Build 18363.657).

Use JSONedit to edit "C:\Users\yourusername\AppData\Local\Opera Software\Opera Neon\User Data\Local State" while Neon is closed.

Under root, create a hardware_acceleration_mode object (if it's not already there). Then, under the "hardware_acceleration_mode" object, create a boolean named enabled (if it isn't already there), set it to false and save your changes. Then, start Neon and see if it works better.

Or, modify Neon's shortcut to pass --disable-gpu or --disable-gpu-compositing (see here) to neon.exe. If that works, you can go into Neon's advanced settings and disable hardware accelleration so you don't need to use the command-line switch. You could also go to chrome://flags and tweak things there (like the "Override software rendering list" flag).