Hm, my guess would be that the issue is/was caused by hardware acceleration or the graphics card driver. In that case there's a command lime switch to start Opera with it disabled (--disable-gpu). But nice to see you got it solved already.