Adobe Flash falsely claimed as "outdated"

  • I'm using Opera 29.0.1795.60 on an older MacBook running OS X 10.75. Almost from one day to the other suddenly Adobes Flash plugin stopped working. Opera tells me, that Flash is outdated and that I should update it, despite that I'm already running the most recent version.

    Here is a screenshot of opera running the Flash Player Version site (http://www.adobe.com/software/flash/about/) with the mentioned error message (german localization):
    http://i.imgur.com/XCOYpPz.png

    Same results with Youtube, of course:
    http://i.imgur.com/3GT1ZkN.png

    I'm already tried running the flash update again, without any results. And btw. other Browsers like Safari and Firefox still work fine.

  • You have adobe flash NPAPI installed which is not the latest version of flash. You have to upgrade it to PPAPI.
    We received a couple of complain from users with NPAPI plugin and we decided to inform users to upgrade to the latest version.

  • Thanks for the help.

    OK, I finally got Flash working again when installing the PPAPI-plugin "Flash Player content debugger for Opera and Chromium based applications – PPAPI" from https://www.adobe.com/support/flashplayer/downloads.html

    The recommended installer for PPAPI doesn't work on my system (it always crashes), so I hope the debugger plugin doesn't have any downsides for normal users.

  • That's too bad. Because when testing a couple of things to get Flash running again, indeed I already tried to install the PPAPI plugin via the preferences pane of the Flash plugin (which just redirects to https://get3.adobe.com/de/flashplayer/update/ppapiosx/). But Adobe's PPAPI installer always crashes on my system.

    Excerpt from the crash log:

    Exception Type:  EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
    
    VM Regions Near 0:
    --> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Volumes/VOLUME/Install Adobe Flash     Player.app/Contents/MacOS/Install Adobe Flash Player
    VM_ALLOCATE            0000000000001000-00000000000d2000 [  836K] ---/--- SM=NUL  
    
    Application Specific Information:
    objc[9133]: garbage collection is OFF
  • Just found another issue with the PPAPI plugin:
    For whatever reason the "click to play"-setting doesn't work anymore. Which is really bad on an underpowered system.
    Is this behavior normal with PPAPI? Or is this something that might be caused by using the debugging version of the plugin (again, the installer for the regular plugin crashes on my setup)?

  • I didnt have any problems when installing PPAPI flash on my system with OS X 10.7. Maybe try to uninstalling Flash and try from scratch.
    I didn't use the debug version but click to play works fine for me with PPAPI plugin.

  • I narrowed down the problem by myself by now.

    Somehow it was some kind of weird interaction of an extension with the updated flash plugin. Weird because click to play seemed to work with all sites but one (and especially one with lots of embedded flash videos) after the flash update.

    The extension that seemed to cause it was "Site-specific Preferences". From one day to the other (exactly the day that NPAPI plugin stopped working) the Operas click to play setting for all pages was overridden by the site specific extension settings from "Ask" to "Allow". Setting back the status within the extension to "Ask" for this specific site solved the problem.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.