Weird browsing lag with Opera 28

  • I've been using Opera for a month and it's been quick and working great. But the past few days I've noticed a very slight lag at times when browsing. Here's what I notice:

    1. A very slight delay when typing on forms on websites (like this one)

    2. HTML5 elements on websites are very slow and laggy

    3. YouTube videos are UNWATCHABLE. They lag, stutter, and run in slow motion and the audio doesn't match with the words. Very bizarre.

    This seemed to happen out of nowhere, I think there was an update so I'm not sure if that is what caused it because I had no issues before.

    I've already tried fiddling with disabling hardware acceleration and all of that and it didn't fix anything.

    My specs:
    Windows 7
    Intel i7-3770K CPU @ 3.50 GHz 3.50 GHz
    16 GB RAM

  • With Opera not running fo into your profile folder and delete the three files that starts with 'session' that you find there. Just a heads up, this will clear any webpages that you had open the last time you exited the browser so you wont be able to continue where you left off. Bookmark them before you delete these files if you need them. Does that fix the problem?

  • With Opera not running fo into your profile folder and delete the three files that starts with 'session' that you find there. Just a heads up, this will clear any webpages that you had open the last time you exited the browser so you wont be able to continue where you left off. Bookmark them before you delete these files if you need them. Does that fix the problem?

    I thought this would be the cause since someone else on here said it fixed it. But when I go into my profile folder there are no files with 'session' in it

  • Go to opera://gpu/. Post results. Be sure to use markdown so the forum doesn't gobble it up.

  • Go to opera://gpu/. Post results. Be sure to use markdown so the forum doesn't gobble it up.

    I'm trying to paste it but not sure how to use the markdown to properly display all of it (it's long). And right now it looks like a jumbled mess when I try to paste it here

  • Just do the 'Graphics Feature Status', 'Driver Bug Workarounds' and 'Problems Detected' sections if that makes it easier. Below you'll see my output. Its fairly standard for a Windows machine.

    Use four spaces at the beginning of each line to indicate a block of pre-formatted text, such as code samples.

    Example:

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Rasterization: Software only, hardware acceleration unavailable
    Threaded Rasterization: Enabled
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    exit_on_context_lost
    scalarize_vec_and_mat_constructor_args
    texsubimage2d_faster_than_teximage2d
    use_current_program_after_successful_link
    Problems Detected
    GPU rasterization is blacklisted on non-Android: 362779
    
    Disabled Features: gpu_rasterization
    Always call glUseProgram after a successful link to avoid a driver bug: 349137
    Applied Workarounds: use_current_program_after_successful_link
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage2D() is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage2d_faster_than_teximage2d
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
  • lando242 May I ask a question. I have used Opera for many years, but am not a computer expert by any means. I am also experiencing the problems mentioned here. I am not able to find the Opera profile folder to see if I have the files with 'sessions' there! Can you help me navigate there please?

  • Opera Menu > About Opera. It says the location of the profile folder near the bottom of the page.

  • Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Rasterization: Software only, hardware acceleration unavailable
    Threaded Rasterization: Enabled
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    exit_on_context_lost
    scalarize_vec_and_mat_constructor_args
    texsubimage2d_faster_than_teximage2d
    use_current_program_after_successful_link
    
    Problems Detected
    GPU rasterization is blacklisted on non-Android: 362779
    Disabled Features: gpu_rasterization
    Always call glUseProgram after a successful link to avoid a driver bug: 349137
    Applied Workarounds: use_current_program_after_successful_link
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage2D() is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage2d_faster_than_teximage2d
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
  • Ditto, same problem, except my lags are about 3-5 seconds long every 20-30 seconds. Opera is now impossible to use.

  • Any fix yet?

  • Did you try the deleting of the sessions files?

  • What is the function of the session files?

  • Read the first reply to this thread, that should cover it.

  • Did you try the deleting of the sessions files?

    When I go to the AppData\Roaming\Opera Software\Opera Stable there are no files in that folder with "session" in them

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.