Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • This is really strange. I was using Opera 28 beta while waiting for the supposed bug on the 27 to be fix. Well guess what? Much the same way Opera 27 suddenly became choppy so did the 28 after about a week; this morning I went to use Opera and the trouble started: lag in typing every now and again, slow to respond to open and closing tabs..

  • I'm still using Opera 28 Beta, and it's still running smooth for me, aside from a few hiccups. It's really weird that Opera's acting like that now.

  • For the past 10 days I had been checking out Opera 27 to see if it would come back to normal while using Opera 28. Yesterday Opera 28 went slow and Opera 27 remained slow. Today Opera 27 is back to "normal". In case you are wondering, I have not installed/uninstalled anything or even rebooted the computer..

  • That is odd, to say the least. I'm using the most recent version of Opera 28 Beta and it's fine for me, but 27 is still painfully slow. What version of Opera 27 and 28 do you have?

  • Heres a thing to try: go into your profile folder (location can be found in the About Opera page) and deleted these files: session.db, session.dbak, and session.db-journal. Make sure the browser is closed when you do this. See if that helps and report back here.

  • I have not seen anything like this - everything seems fast - even tho I am using XP on a slow machine?

    Has anyone tried backing up the bookmarks, using an uninstaller to get Opera 27 off, delete opera folders and other dross in the registry....... and then re-installing from scratch?

    I know its like kicking the tele to make it work.... but it seems to work for Microsoft!

  • I have been using the latest versions of Opera 27 and 28.

    By the way peterx666, I loved your metaphor about kicking the tele! Hella of appropriate. I thought about it but chose to try another version, then Chrome, then back to Opera 27 because I could not bring myself to do the clean uninstall. I did try using CCleaner to delete some of the clutter but did not even delete the cache because every time I do it I end up hating the process of entering stupid secret questions for many websites.

  • Heres a thing to try: go into your profile folder (location can be found in the About Opera page) and deleted these files: session.db, session.dbak, and session.db-journal. Make sure the browser is closed when you do this. See if that helps and report back here.

    I had the same problem and this solution is perfectly work for me, thank you.

  • Heres a thing to try: go into your profile folder (location can be found in the About Opera page) and deleted these files: session.db, session.dbak, and session.db-journal. Make sure the browser is closed when you do this. See if that helps and report back here.

    Lag was driving me nutty. Disabled extensions and plugins; no impact. Deleting session.db (which had grown to over 200 MB) did the trick. Thank you!

  • I'm having the lag issues, although not as bad. When I try going to the profile folder I don't see any of these: session.db, session.dbak, and session.db-journal

    Any idea?

  • no session* files on Arch linux (~/.config/opera/).

  • They fixed the session issue several releases ago. So, if you are using Opera 24, its probably something else.

  • These issues were designed deliberately to force people onto the newer versions of opera which underneath is really NSA's chrome engine but on the surface is made to look like Opera. The fact is that the old Opera browser doesn't exist anymore and all the new browsers are in effect spy machines. Wake up to what going on around you people. They are preparing a global currency rest and martial law everywhere. At what point will you realize that you've been duped???

  • Someone needs to either get off their meds or double their dose.

  • Don't you believe in Martians?

  • I noticed if I disable trend micro anti virus then the speed issue goes away...