Opera 26 updated to 27 even when about page said update checker is disabled.

  • I downgraded from Opera 27 to 26 due to the high cpu usage issues. I disabled the update checker by putting in a environment variable and checked in the help -> about to make sure it would not update, but today after closing and re-opening it has updated. I will lose my entire user profile and settings now when going back to v26 because they are not compatible with each other.

    Some requests:

    Proper disabling of updates. I use a limited 3G connection at home and don't want automatic updates.
    Please fix the CPU usage issue when opening new tabs, it makes the browser really slow.

  • From rafaelluik (April 2014)

    Link: [https://forums.opera.com/topic/2301/disabling-auto-updates-saving-certificates-displaying-full-url-and-grouping-tabs/38]

    "Go to Windows's System / Advanced System Settings, in the Advanced tab click the button to manage the Environment Variables and add one called "OPERA_AUTOUPDATE_DISABLED". Done."

    It helped me :)

    C

  • I have gone the extreme route and deleted the Opera updater program from my pc.

  • A little more detail on cr2004's comment. Just now going to try it on my PC.

    http://blogs.opera.com/desktop/2014/03/opera-developer-22/#comment-1316232376

  • I confirm OPERA_AUTOUPDATE_DISABLED can't stop auto-updates from happening by itself anymore.

    If you really want to stop the auto-updates try this:

    • Set the OPERA_AUTOUPDATE_DISABLED environment variable, you still need it to prevent Opera attempt to auto-update when you run it.
    • Search for the Windows' task scheduler, it's a Control panel item.
    • You should see a list where one of the items is "Opera scheduled Autoupdate (...)", right-click it and select disable.

    But please don't do that if you aren't dependent on a feature that has been changed or removed in the latest versions. If you absolutely must do this, don't forget to check info about new versions once in a while, they contain security updates and will give the best compatibility with websites, the system, etc.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.