:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Opera 12 Unable to complete secure transaction

  • I am using Opera 12.16 - been using it for a while but now when signing onto sites .... say Amazon.... I get a message with an error screen saying..

    Unable to complete secure transaction

    This seems to happen with loads of HTTPS urls which makes Opera useless

    Is there a work around for this?

    oete

  • Yup. Upgrade your browser. You are using a version of Opera that hasn't been updated in 2 years.

  • @peterx666 Please provide an url

  • Https sites require certain handshaking to occur between the website server and the browser that determines the most secure protocol and which encryption method that can be mutually used by both the browser and site. It also involves certificates being available locally to the browser (which certs are essentially "authorized" public keys to the chosen encryption methods used by a particular https site, and which therefore must be current and unexpired). In order for https communications to work, all these details must match up perfectly... and you get the message you mention when even one detail doesn't match.

    Usually the problem involves the current, proper, officially-issued certificate for a site not being available to the browser (either locally in a browser file or as part of the operating system's record store, depending on browser design). However, if the particular browser in use doesn't support the secure protocols and encryption methods demanded by the site, even a 'current' stored cert can't be used... that is, the encryption keys in the cert won't match the security methods available to the browser. Problematic as this can become for older browsers with lesser protocol and/or encryption options, it's made even more complicated because many site servers will frequently 'sniff' the browser brand/model being used and may simply elect to not even bother offering secure communications to it... and a user again gets the message you mention.

    Because certain previously-used secure protocols are now deprecated (because of very recent exploits like Poodle), websites and browsers are dealing with that in various ways. One of the ways is to avoid using exploited protocols and to use tighter encryption methods linked to their remaining protocols, which of course requires that visiting browsers (and certs) accommodate these - but a browser frozen in time has a difficult time doing that. Depending on how the protocol in use and the site's certs are structured, it is still sometimes possible to negotiate a mutual combination of protocols and encryption methods that allow the https to work... in some instances, perhaps by manually adding new cert records copied from another system/browser. But in the end, it will always be a losing battle. Various "tricks" might be found to fool both browser and site to get a problem https site to work... but it's just a matter of time until things evolve so far that no amount of such tricks will resolve it.

    At some point, one must ask some basic questions. Among these is how much work does the user want to undertake to constantly plugging the cert holes, and how much reliance can be placed on the ensuing security even then? At what point is it simpler and safer to merely use a newer browser for secure web browsing? I've believed, ever since Opera announced that they were going to stop developing Presto Opera, that eventually what "kills" Presto would be the evolution of web protocols/standards/techniques that finally leaves the browser in the dust, at least for important or demanding usage. That day is now unfolding, in part through the vehicle of evolving https security practices.

  • Opera 12 has many problems with modern SSL ciphers and checking certificates for validity.
    There's no workarund and i dont think for this old version it will be fixed..

  • Thanks for your helpful expanation all .... most useful

    But now I am confused as a new post on this section seems to have the same problem with version 26? and a later version of windows than my XP....

    "Hi everyone, I'm on Windows 8.1 and using Opera 26; the problem is it's keeping on giving me the message "This web page is not available - the web page ... could be temporarily not reachable or it could have changed address": this's been happening for the last few days both with bookmarked websites and google results: is anyone able to tell me what's going on?"

    Further somment appreciated

    Incidentally seem to have lost all the graphics and boxes etc on these pages too

    Tried uninstalling and re-installing version 12 but it has not made any improvement

    Comment appreciated

    Pete

  • Incidentally seem to have lost all the graphics and boxes etc on these pages too
    Tried uninstalling and re-installing version 12 but it has not made any improvement

    You haven't enabled any of the style options in Opera by accident ?.

    'O-Menu / Page / Style' and make sure 'Author mode' is selected, and any of the style options in that list below 'Author mode' are not ticked.

  • on giving me the message "This web page is not available - the web page ... could be temporarily not reachable or it could have changed address":

    That may be: Problems to reach the domain, server problems, problems with domain resolution.

    Opera 26 has no problem with SSL (https://) sites, if so i would have recogniezed while surfing.

  • Adding to what I already wrote above, have a check of 'O-Menu / Page / Images' and make sure 'Show images' is selected too.

  • Opera 12 does have problems with a very small subset of https sites (see: https://forums.opera.com/post/54114), but Amazon.com isn't one of them. Something is wrong locally.

  • May be a virussscanner software intercepts SSL web connections. Most oft problems occur with such "security" software breaking secure connections.

  • OK Guys .... I have bitten the bullet and installed version 26 along side 12 (different folders tho)

    Must say I am impressed at eh speed of the thing! imported bookmarks from the old one - problem cant find how to "manage bookmarks" as they are all installed on a low level folder but can put up with that wor now

    Good news is up to now not found a sit that does not work!

    Wow

    Impressed

    pete

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.