How can I disable the ctrl+space shortcut?

  • I imagine this is a somewhat common question as it's literally the absolute worst idea in the history of computers so I apologize if it's been asked before; but I've had no luck with The Google as far as finding a way to disable this stupid horrible shortcut. Is it possible? If so, how do I do it??

  • Edit the entry in the keyboard shortcuts file and change or remove it. You can find the details of how to do this from this post:

    https://forums.opera.com/post/36754

    As for being common I had no idea that shortcut existed until you mentioned it and I've never seen anyway complain about it. The two keys aren't even that close together...

  • Hi @captaincolon, you can disable it as follows:

    1. Start the Opera, go to Opera's menu, select "About Opera" (or press Alt, then a), copy the path to the profile, and close the Opera,

    2. Open Windows Explorer (WinKey+E), paste the path into the address bar, find the "Preferences" file, and make its copy (e.g. "Preferences-back" - just in case, if you make a mistake in the syntax, so then you can overwrite the original file with the copy, to revert the changes), and then open the "Preferences" file in your text editor,

    3. At the very top (in the second line), after the first occurrence of the "{" sign, add the code as below:

    "Keybindings": {
          "Basic": {
             "NavFavorites" : [ "Alt+Home" ]
          },
          "Settings": {
             "AdvancedEnabled": true
          }
       },
    

    after you add the code, it should looks as below:

    {
       "Keybindings": {
          "Basic": {
             "NavFavorites" : ["Alt+Home"]
          },
          "Settings": {
             "AdvancedEnabled": true
          }
       },
    

    Small note: if sections as above already exist, then you should edit them, to be the same as above, and do not add new.

    Save the changes, close the file, and launch the Opera 😉

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.