Can't connect to Wifi network requiring logon on browser page

  • I have downloaded Opera on to several devices (phones, tablets) running Android; all versions 4.2 and higher). I noticed on my last trip that when I was in hotels, airports etc. connected to the public Wifi and was required to log on first. I'm familiar with this and usually when opening a browser the page of the hotel, airport etc is the first page and one goes through the log on steps. However consistently on all the devices, Opera (version 26.0.1656.86386) would not open the required log on page. If I had a different browser on the device and I opened that browser the log on page would be there and once I had logged on, I could then open Opera and it functioned correctly.

    It was particularly unfortunate on one device as I only had Opera since I was looking for a small file size browser for that device and had selected Opera.

    Since I am new to Opera perhaps I have a setting wrong. Any assistance would be appreciated.
    Thank you

  • I have connected to WiFi with login required, I just have to try to open a page and I get the login page.

  • Yes, I tried that. Normally the log in page shows immediately when opening a browser, this did not happen nor did it happen when I opened another tab.

  • I had same experience in Germany in bus .. Opera classic and opera 26 didn't open log in page.. Opera beta 27 did.. Im not surprised opera 26 is worst than 25,24,23,22,21.. Even opera beta 26 is more stable then opera official 26

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.