Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

Hello, in order to introduce new security features and enhance your experience with Opera Forums we have to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button in the upper-right corner of the page.
This is a one-time action. Sorry for any inconvenience!

Sick behaviour of photo/picture viewer

  • Opera (ver 12.16 Build 1860) worked normally - for example: searched in google the word "drum" > clicked on the link "photos" and there were big photos side by side > clicked one of them, browser showed bigger photo with "next" and "previous" option. Normal.
    Then on a nice day (Opera made a kind of upgrade?) by clicking on the link "photos" it started to show kind of thumbnails and clicking one of them directs to photo's homepage.
    Is there a way to turn this behaviour back to normal?

    Thanks,
    Mac.

    Platform
    Mac OS X
    System
    10.7.5

  • Google blocks the real Opera browser (v. 12.x and earlier versions) and provides Opera with a simplified versions of its web-pages (including search engine) with a lot of missing functionality.

    It can be fixed with selective masking of Opera for google's pages.

    • Find your Opera's profile folder (type opera:about as an url in the Opera's address field and look for the path in "Opera directory"). Remember it.

    • Close Opera

    • Go to your Opera's profile catalog("Opera directory" path from the opera:about) using file manager

    • Open override.ini with a text editor

    • Add at the end of [Overrides] section these strings:

    plus.googleapis.com

    plus.google.com

    apis.google.com

    google.com

    google.XX

    (NOTE: where XX is a national domain of your country. For an example, ".fi" - Finland etc. DO NOT INSERT this note into ini file!)

    • Then add at the end of the override.ini file:

    [plus.googleapis.com]

    User Prefs|Custom User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10; rv:33.0) Gecko/20100101 Firefox/33.0 Opera 12.16

    [plus.google.com]

    User Prefs|Custom User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10; rv:33.0) Gecko/20100101 Firefox/33.0 Opera 12.16

    [apis.google.com]

    User Prefs|Custom User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10; rv:33.0) Gecko/20100101 Firefox/33.0 Opera 12.16

    [google.XX]

    User Prefs|Custom User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10; rv:33.0) Gecko/20100101 Firefox/33.0 Opera 12.16

    (NOTE: where XX is a national domain of your country. For an example, ".fi" - Finland etc. DO NOT paste this note into ini file!)

    • Save changes and launch Opera

    • Now you can use a fully functional Google search engine

    p.s. There is another solution with a global masking via opera:config parameter(custom user-agent). Do not use it! It can cause more problems than fixes!

  • I accidentally skipped one line but can't edit the original post.

    Also you should add at the end of the override.ini file these strings:

    [google.com]

    User Prefs|Custom User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10; rv:33.0) Gecko/20100101 Firefox/33.0 Opera 12.16

Log in to reply