HTTPS-Problem bei der Google-Suche

  • Hallo Christoph142,

    da ich keine Möglichkeit finde, Dich direkt anzuschreiben, versuche ich es hier.

    Wie wir festgestellt haben, zeigt Opera bei der ganz normalen Suche über Google (Google als Standardsuchmaschine) einen Fehler an "Diese Webseite ist nicht verfügbar
    Die Webseite unter https://www.google.de/search?client=opera&q=blablabla ist möglicherweise vorübergehend nicht erreichbar oder wurde dauerhaft auf eine neue Webadresse verschoben."

    Löscht man das "s" aus https, so dass eine unverschlüsselte Suche über HTTP entsteht, dann klappt die Suche. Ebenso klappt genau eine Suche, wenn man vorher den Cache leert. Bei der zweiten Suche geht das schon nicht mehr und erzeugt die obige Fehlermeldung.

    Du hattest im offiziellen Opera-Blog geschrieben, dass es nach Deiner Feststellung hilft, wenn man in opera:flags SPPDY/4 ausschaltet (opera://flags/#enable-spdy4). Das hat bei mir auch nur einmal geholfen, nämlich direkt nach dem Neustart, weil auch da erstmal wieder der Cache geleert war.

    Kann es sein, dass Du noch weitere Einstellungen verändert hast, um hier einen Erfolg zu erzielen? Ich habe mal im Suchfeld "Experimente" links HTTP eingegeben und mit den angezeigten 4 Treffern herumgespielt (besser gesagt nur 3, opera://flags/#enable-simple-cache-backend habe ich nicht verändert), aber keine Verbesserung erreicht.

    Natürlich habe ich auch mal alle Erweiterungen aus- und wieder eingeschaltet. Keine Änderung. Mit Google Chrome, Firefox und Waterfox funktioniert unter gleichen Voraussetzungen alles wie gewohnt.

    Wie sieht es bei den anderen aus?

  • Funktioniert hier in Opera 12.17 und 26.0.1656.60 problemlos.

  • Ich hatte das Problem zusammen mit Entwicklern unter die Lupe genommen. Bei mir hat sich das Problem seit dem Ausschalten von SPDY erledigt. Ich hab aber auch eine Erweiterung, die das Problem (bei mir) löst. Ich lasse sie dir morgen zukommen :up:

  • Hier ist sie. Lass mich wissen, ob es das Problem bei dir löst :sherlock:

  • In der Tat tritt der Fehler jetzt nicht mehr auf. Kannst Du mir sagen, was da genau passiert?

    Danke schön auf jeden Fall. Dann kann ich die Einstellungen in opera:flags wohl in Standardeinstellung lassen.

  • Die Extension wird wohl bei Operas Anfragen an den Server die Kompression SDCH (Google erfand die!) deaktivieren, in dem was aus dem HTTP-Header entfernt wird.

  • @gwen-dragon genau so ist es.

    Wir haben das Problem als eine Wechselwirkung zwischen dem experimentellen SPDY Protokoll und der SDCH Kompression identifiziert. Die Hoffnung ist, dass sich das Problem von selbst in Chromium löst, bis SPDY marktreif ist. Deswegen ist von Opera im Moment kein Fix zu erwarten. Seltsam ist nur, dass du den Fehler scheinbar auch ohne SPDY hast. Hab ich das richtig verstanden @ralf-brinkmann?

  • Richtig. Egal, was ich da einstelle, der Fehler kommt immer wieder. Immer ab der zweiten Suche. Wenn vorher der Cache geleert wurde (zum Beispiel nach einem Neustart), dann klappt die Suche einmalig, aber ab der zweiten Suche nicht mehr. Und nur bei Opera. Bei Chrome, Firefox und Waterfox tritt dieses Problem nicht auf. Die haben es anscheinend von Anfang an rausgefiltert oder so.

  • Übrigens wäre es auch für andere User schön, wenn es für diese Erweiterung eine ganz reguläre Downloadquelle gäbe, die man sich irgendwo abspeichern könnte.

  • @christoph142 Warum lädst du die Extension nicht auf addons.opera.com hoch?

  • Die ist von einem von Operas Entwicklern. Ich hab zwar die Genehmigung, sie zu verbreiten, aber ich möchte ungern das Eigentum anderer im offiziellen Store hochladen ;)

  • Dann schreib ihm doch, dass er das bitte machen soll.

  • Um ehrlich zu sein, Ralf, bist du außer mir der einzige, der sich jemals über das Problem beschwert hat. Ich sehe deshalb nicht die Notwendigkeit dazu. Wenn sich die Berichte häufen werde ich es aber sicher nachholen.
    Ich soll dich von den Entwicklern übrigens noch fragen, ob es mit allen flags in Standard-Einstellung auch auftritt. (Du hast zwar oben

    Dann kann ich die Einstellungen in opera:flags wohl in Standardeinstellung lassen.

    geschrieben, aber ich konnte nicht zuordnen, ob sich das nun auf alle oder nur die 4 aus der Suche bezogen hat) ;)

  • Das hat sich auf die 4 aus der Suche bezogen, nicht auf alle. Das habe ich noch nicht getestet.

  • Könntest du das bitte mal versuchen? (Du kannst deinen Profilordner einfach kopieren und nachher wieder zurück überschreiben, damit du deine config nicht verlierst) :sherlock:

  • Hach, was macht man nicht alles für die besten Freunde!

    Also, ich habe Opera geschlossen, den Profilordner umbenannt und Opera neu gestartet, so dass ein neues Profil mit Standardeinstellungen angelegt wurde.

    Erste Suche: Klappt. Wie bisher.
    Zweite Suche: Fehlermeldung. Geht erst wieder nach Leeren des Cashes.

    Scheint also nicht an Veränderungen in opera:flags zu liegen.

    Ach so: Ich habe es dann noch einmal mit SPPDY/4 eingeschaltet und mal mit ausgeschaltet probiert. Kein Unterschied. Erste Suche geht, dann nicht mehr. Cache geleert, geht wieder.

  • Frei nach Foierzangenboffle: je'z fragen wir mal janz doof: Hast du 'nen Feuermauer oder Bakteriensucher, der dat arm' Internetstöberer stört? ;)

    AV, Desktopfirewall oder gar Router (ja, T-Com hat schon mal was bei den eigenen Routern verhunzt) können da stolpern oder Netzwerk kaputtfiltern.

  • Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser? Nicht bei Google Chrome, nicht bei Firefox oder Waterfox? Alle mit den gleichen Einstellungen?

    Ich habe zumindest auch schon mal versucht, alle Blocker und Erweiterungen auszuschalten, hat aber auch nichts geändert. Die Windows Firewall und NOD32 werde ich dafür ganz sicher nicht ausschalten, zumal NOD32 sowieso das beste ist.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

  • Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser? Nicht bei Google Chrome, nicht bei Firefox oder Waterfox? Alle mit den gleichen Einstellungen?

    Das ist in der Vergangen oft genug genau so aufgetreten, wobei das gestörte Programm nicht immer Opera hieß.

    Die Windows Firewall und NOD32 werde ich dafür ganz sicher nicht ausschalten, zumal NOD32 sowieso das beste ist.

    Wenn du mögliche Fehlerquellen nicht ausschließen willst, so ist das dein Problem. Es spricht ja gar keiner davon die dauerhaft zu deaktivieren. Wobei die Windowsfirewall eher unverdächtig ist und es oft genug nicht genügt, die Sicherheitssoftware zu deaktivieren.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

    Diese Information hätte in den Startbeitrag gehört.

  • Vielleicht hat deine Sicherheitssoftware ein Update inzwischen bekommen, das stört?

    Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser?

    Ja, das gabs früher mit Opera und Firewall/AV öfters bei komprimierten Daten.
    Wenn allerdings Opera 26 und Chromium wirklich Software für Netzwerk benutzen sollte es nicht auftreten. Aber woher soll ich das wissen, was Opera da sonst noch reinbaut.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

    Die Kompression gibt es schon länger (seit 2009), Google benutzt es auch seit Jahren. Sollte als den Opera und Chromium-Entwicklern bekannt sein.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.