Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 26.0.1656.32 is extraordinarily slow!

  • Hello,

    I haven't been using Opera for a while as there was no easy and intuitive way of using DuckDuckGo. A couple of days ago I started Opera, updated and discovered that DuckDuckGo is among the strd. search engines. Much rejoice! However, the browser is almost unusable. Everything crawls. Opening a new tab, clicking a link, opening Operas "settings" or "about opera". I have it installed on both my workstation and my laptop and the browser behaves similarly on both.

    After clinking something or opening something in a tab it takes approx. 15 seconds for Opera to begin loading. It doesn't hang or freeze, it just waits.

    I have tested both beta (26.0.1656.8) and developer (27.0) and the are both as fast as I am used to Opera being. Beta does not have DuckDuckGo and I am not really comfortable using developer, so I am wondering if anyone else are having these issues? Is there a fix or will I have to return to firefox for a little while longer?

  • Probably the same issue as this:

    I did some monitoring, and there is tons of file and registry reading when a new tab is opened, so I suspect that the slower the hard drive is, the longer it takes to open a new tab.

  • When was the last time you defragged your hard driver and ran a cleaner such as Glary Utilities or CCleaner?

  • I regularly clean my HDD using BitDefender or TuneUp, but i rarely defrag. I will do that and see if it helps, but my Workstation-setup was formatted about two months ago, and Opera is the only program that seems to be running slowly.

  • I was having the same problem on opera 26.0.1656.32 I read the comment about disabling the extensions...went and disabled all four that i had active, and hey presto, the tabs loaded. while i was in the settings page, i also deselected 'Use hardware acceleration when available' under 'system' at the bottom of the page. this last action didn't seem to change anything though. so try and disable all your extensions and see if that helps.

    i'm really sad that we're having all these issues. i have been using opera for more than 11 years now, and really miss the old functionality of opera 12 and before. please, please, please, sort out these issues. i have really enjoyed using opera in the past, most of all sessions, what a miss that is. please stay on your own path, as like before. you were so innovative; i just wonder why you couldn't make the chromium version function the same way as the previous. what's that old saying?...if it's not broken, don't try to fix it!

  • If disabling an extension solved your problem then Opera was not the source of your problem, the extensions was.

    most of all sessions, what a miss that is.

    Session Buddy, the chrome extension, can be installed in Opera if you have the 'Download Chrome Extension'.

    i just wonder why you couldn't make the chromium version function the same way as the previous

    They've been working on the new version of Opera for less than 2 years. The old version of Opera was 17 years old. It takes time to replace 17 years worth of work.

    if it's not broken, don't try to fix it!

    Have you used Opera 12.17 lately? Seems every week that goes by another website no longer works with it. Many of Google's pages broke or were reverted to older styles. Outlook/Hotmail/LiveMail broke over a year ago. So did Chase's website. The list goes on and on. It has simply gotten to the point that the dev team was spending more resources keeping then engine up to date then they were making the browser better. By using google's engine they can spend more time working on improving the browser and less time worrying about engine problems.

  • Mine also same. It was extremely slow with Opera 26.0.
    Switch back to 12.17, then everything back to normal.
    Forget to update it to new version.

  • I had a similar problem. It was getting better for me after I disabled the following flag:

    Maybe it's worth trying it on your machine.