Opera (12.17) opens itself after hiding to notification area

  • I have value 2 in setting "Show Exit Dialog" in opera:config, so Opera will be hidden to notification area, when Close (x) is selected. Hiding to notification area works fine, but after 10-15 seconds Opera reopens itself. After 4-5 reclosing/rehiding Opera may stay hidden, but this problem is just annoying. I have no idea why this is happening. This happened also with 12.16 version.

  • Is there any Windows setting which might cause this problem? I have Windows 7? Opera auto reload setting does not seem to cause this. This is not happening every time I close/hide Opera. Maybe every 2-3 time.

  • Does it display anything when it spontaneously opens, or is it just a blank page?
    🙂

  • It doesn't display or open anything. I haven't noticed any changes. Typically I have 3-4 tabs open and one is always Opera Mail, but that isn't active tab when I hide Opera and it is not active when Opera has opened itself.

    So same things happens if I reopen Opera myself from notification area by double clicking or right-clicking and selecting "Open Opera", but now it just happens automatically.

  • Does it open spontaneously if you hide it with no tabs open?
    🙂

  • Whoa, may it be a mouse gesture?

  • It's not being triggered by a keyboard short-cut by any chance ?.

  • Does it open spontaneously if you hide it with no tabs open?

    After posting the first message Opera has not opened spontaneously, but next time this happens I will try to close all tabs and see what happens.

    Whoa, may it be a mouse gesture?

    I have disabled mouse gestures in Opera and I guess it would not work when Opera is closed/hidden to notification area.

    It's not being triggered by a keyboard short-cut by any chance ?.

    I guess I would have noticed, if it was keyboard short-cut. But I cannot be 100% sure about this. When changing to Windows 7 I accidentally started Magnifier application using some keyboard short-cut, but I noticed that immediately and disabled that short-cut.

  • Finally I found the reason. This happens when tab shows error message about certificate problem. It might be that any error message causes this. Opera does not activate the tab with error message, so I did not realise it was causing this. I think Opera should activate the tab or not reopen itself.

  • Well, Opera 12 is dead. It wont be improved anymore as the dev team is focused in the current version of Opera. Sorry.

  • @ptuikka

    I am using "Block self-restoration" option in Actual Window Minimizer program. This (or similar utility) should help to prevent Opera's self-restoration from a minimized state.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.