Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Disable Surface Pro on-screen keyboard for Opera

  • I've switched to Opera on my Surface Pro (V1) because I was tired of IE 11 crashing and having to recover web pages many times a day.

    However, whenever I touch a text box on a web page or the URL field , Opera brings up the on-screen keyboard even though the physical keyboard is connected. If I use the track pad on the Type Cover and click on the same field, the cursor appears and I can type normally, but as soon as I touch a field, up comes the on-screen keyboard which takes a couple of seconds to clear and resizes all my windows.

    None of my other desktop programs do this (IE11 certainly didn't), and I'm looking to find a way to disable the on-screen keyboard when using Opera and/or force Opera to use the physical keyboard like all my other desktop apps.

    I've tried looking on the MS and other forums but haven't found anything that helps. For example, this post: http://answers.microsoft.com/en-us/surface/forum/surfpro-surfdevice/disable-the-on-screen-pop-up-keyboard-when-another/52a88e4f-2d2b-49d7-9b85-edfa60a40cd4 describes my problem but none of the proposed solutions work.

    Is there a setting or registry key that would help?

Locked