Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Mail has a problem with Microsoft mail IMAP

  • Hello, I hope Opera Mail is not dead yet. I was trying to find some alternative to it but it seems like there isn't any software as comfortable as Opera, at least for Windows. I'm using multiple accounts, most of them are using Microsoft e-mail services. For a long time Microsoft hadn't allowed IMAP for their services, only POP3, however since they are allowing to use IMAP I have some issues with the mailboxes. Sometimes Opera doesn't download all the mails or seems to be stack with downloading huge number of e-mails. It bothers me especially when some important e-mails are not downloaded and I have to go to the website to check the e-mail there. Moreover this problem seems to be indicated by icon of small yellow triangle with exclamation mark next to the account name, however I don't get any information why is that. No warning message or error message at all. I also use some other e-mail account which is not provided by Microsoft and this account seems to work just fine without any problems. So the problem appears only with Microsoft account. I also use Avast! free as an antivirus and all of my Microsoft accounts have SSL/TLS turn on.
    Does anyone have a clue why is that and what shall I do to repair it? It is very annoying and since I can find worthy alternative to Opera Mail, I'm lock with this client not working perfectly. Thanks.

  • You can turn on logging to get more info on the connection including errors and at what point a connection stalls/stops.

    For the other problems, make sure you don't have low-bandwidth mode turned on for your IMAP accounts. Then, close down Opera and edit incomingN.txt (where N is the number for the account as seen in accounts.ini) for each of your IMAP accounts in the mail folder. Make sure QRESYNC is disabled. If it wasn't disabled and disabling it doesn't help fix the issues, try forcing a single connect. You can try disabling uidplus if the others don't work, but I doubt it'd help.

    In accounts.ini in the mail folder, under the section for each IMAP account, you can disable body structure support. The server would have to be pretty messed up for you to have to disable this though.

    Besides that, make sure you you have "include this account when checking manually" and "check for new messages every..." set for each IMAP account. The check interval should be between 9 and 31 minutes. Don't set it lower than 10 unless you know the IMAP servers wont' have a problem with it and disconnect Opera for connecting too much. Also note that Opera supports IMAP IDLE and will use it if the server supports it. But, you still need to have Opera check for new messages every once in a while or IDLE will time out and you won't receive any new messages.

    It's also possible that your IMAP accounts are just messed up. Deleting them and adding them back in might help. Or, if you have to, delete the whole mail folder and start over. See this page if you have POP messages you need to save.

    On the IMAP tab in each IMAP account's properties, disable Opera's spam filter and make sure to set your folders.

    Also, before you do anything, click the check/send button drop-dwon and choose "resynchronize". If that fixes things, it's likely it's a QRESYNC problem.

    Opera Mail is dead though.

  • Thanks, although nothing has helped at all. I checked QRESYNC, it was disabled, then I tried to turn off body structure, same result. Even in log file there is nothing indicating the problem. Well, that probably means that I really have to look for other mail clients. Do you have any tips? Something free, up to date and with the same layout like any other modern e-mail client (not like Thunderbird with mail list upon the mail body.) Thanks

  • not like Thunderbird with mail list upon the mail body

    Thunderbird has a vertical layout that's like Opera's default list and message on right layout.

    Options -> layout -> vertical view.

  • Did you try forcing a single connection though? That one has the highest probability of success.

  • Yes, I did, however without any success. It seems like it is not only my problem, it is problem of all users of microsoft e-mail services, as I see in this topic:
    And what is even worse, I tried to switch to Thunderbird, however the problem seems to be the same. Thank you for your help. F**ing Microsoft...