Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Website opens in mobile view, while it shouldn't

  • OK, I've used the addon User-Agent Switcher which fixed this.

    Please close the thread.

  • Please close the thread.

    Please don't.

    How did it happen in the first place? What do you think?

  • The situation has been resolved. The thread should be closed.

  • The situation has been resolved.

    Not at all...

    How did it happen in the first place?

    :sherlock:

    The thread should be closed.

    Not at all!:sherlock:

  • The OP resolved HIS problem. He asked that the thread be closed. YOU are trolling here as you are in so many other threads... looking to stir up as much trouble as you possibly can. What "is" your problem?

  • Well, as you can't see the point, let it be this way: if the user do not answer the question how it happened within a certain period of time, the thread sinks and, unless the site carers haven't done any improvements to the search by then, it [the topic] becomes unsearchable. So it'll be an easy solution then to just DELETE the thread.
    But as long as NOW we're having a new issue with the browser on our hands, it won't be any sane at all to just shut the discussion up.

  • The thread will not be deleted in any event. The thread "should" be closed, plain and simple. Evidently that seems to be beyond your grasp.

  • The 'new' issue is browser sniffing maybe, the site's owner should be contacted.

  • But we do not KNOW the cause - the user *:zip:*s like a partisan under questioning...

  • I think the answer is fairly obvious from my reading of the first two posts.
    The OP is almost certainly correct that the site author has assumed (wrongly) that Opera is mobile only, and has set their site to serve the mobile version if Opera is detected from its user-agent string.
    The OP has used the User-Agent Switcher extension to mask Opera as being another browser, and the site now works correctly.
    The site owner just needs to be told of their mistake, that's the cause!
    🙂