Mouse hovering doesn't work

  • In Opera Beta 25 for Linux I'm having this issue where moving the pointer over a link doesn't turn the pointer into a hand, the link doesn't get highlighted and the destination url doesn't appear at the bottom. If I move the scroll wheel up, then the mouse-over event triggers and everything that should happen happens.

    For example, in the top of this page, next to the Opera forums logo there's a menu icon, moving the mouse over it doesn't open it, I have to move the scroll wheel while pointing to make it appear. It also works if I move the scroll wheel down, but the item will move away from the pointer and will not have the intended effect. And on the other hand, once I trigger it, I can move the pointer away and the menu won't hide until I scroll or click on something.

    It's surprisingly not as annoying as it might seem at first, but it's obviously not right.

    I don't know if it's got something to do with my setup: I'm on a dual-head display set up with xrandr, xinerama is enabled. I'm using fluxbox, I don't have neither Gnome, Unity nor KDE installed.

    Anyone experiencing similar behavior?

  • Have you tried unplugging the mouse and plugging it back in ?.

  • I just tried and no, it didn't work. Hovering works in every other app, including Opera 12 and Chrome. I'll try Opera Next.

  • Opera Developer 26.0.1646.0 has the same problem.

  • I just figured out that it's some sort of incompatibility with Synergy 1.4.15. It happens in my main computer, the one which runs the server is also the one running Opera and having the glitch.

    I noticed 'cause I killed the process for an upgrade. Sadly, it also happens with 1.4.16 and with 1.5.1.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.