Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I installed Opera on the latest Manjaro Linux with the Plasma Desktop and added my extensions and tweaked the browser settings to my liking and all seemed good. I went to watch one of my shows online a couple of day ago and on the video I get "Browser not compatible You may need to update your browser". I have other browsers installed with the same extensions and I never have this happen in them. Anyone have any idea why Opera would be the exception to the rule? Thanks

    https://the-young-and-the-restless-full-1.blogspot.com/2021/09/the-young-and-restless-9-13-21-full.html

  • Love the fact that this thread has been ignored, Not. I noticed that some threads about video issues are locked for no reason. Example below. As long as Opera has been around I know someone knows what's going on with certain videos and how to address the issue. If someone would be so kind as to point me in the right direction that would be great. Thanks

    https://forums.opera.com/topic/51446/netflix

  • @mrgrimm I believe it is a known problem.
    Even I have a thread with the same problem. I have an script to solve it, but I don't remember exactly why I was doing each step. I apply this script after any Opera update to solve the videos issue:
    sudo mv /var/lib/dpkg/info/opera-stable.postinst /var/lib/dpkg/info_beto
    sudo apt-get update && sudo apt-get -f install
    sudo cp ~/Beto/Keepass/libffmpeg.so /usr/lib/x86_64-linux-gnu/libffmpeg_h264.so
    sudo mv /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so.orig
    sudo ln -s /usr/lib/x86_64-linux-gnu/libffmpeg_h264.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so

    I already have downloaded libffmpeg_h264.so into a permanent path and copy it overwriting the new one.
    You'll need to adjust it to your path, but it is 100% working.
    Hope it helps.