HiDPI problem

  • Hi,
    I noticed unusual behavior on my opera 24.0. After some googling I read changelog and found reason why it happening. I use 15’’ display with Full HD res. Problem is that pages are not displayed as they should. They are zoomed. It is probably because of “Fixes and enhancements for how Opera handles HiDPI on Windows“. I tis probably cool feature for people who use opera for daily browsering. But I use it for designing webpages and that feature is really annoying.

    Is any possibility to disable that feature, or is any possibility to downgrade opera and not “loose” saved passwords, because they are kind of deleted after downgrade.

    Thanks for answers.

  • You could try to see if any of the current HiDPI flags can help under: opera://flags/ (Just search for HiDPI and the ones concerning it should show.)
    If not there is definitely a fix for it being made as we speak.

  • I found many flags about HiDPI but it didnt help.

    For now I downloaded Lastpass, downgraded opera and deleted opera_autoupdate.exe to prevent next automatic updates.

  • The only fix AFAIK is to run Opera with the switch "--alt-high-dpi-setting=96".
    I have complained ceaselessly about this on the Developer stream blog, but nothing has been done.
    It appears that as far as Opera are concerned it's working the way it should do!
    A setting exists in Firefox to correct this same problem, it's buried pretty deep but it does fix it.
    I'm hoping a similar option will be added to Opera, but I'm not holding my breath!
    :down:

  • @jaanesen I CC'ed you in DNA-24328

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.