WebM VP8 issue when Flash plugin enabled

  • I found an issue with WebM VP8 codec - when Flash plugin is enabled, Opera stops using WebM VP8. This causes problems when using Youtube. I'd like to play yt movies on html5, but most of them are coded by webm vp8. Flash plugin disables possibility of play as html5 and forces to play as flash video.

    Is there any way to have installed and enabled Flash plugin and at the same time play youtube videos as html5 webm vp8?

    Here is when flash plugins disabled:
    http://i.imgur.com/Pev3eTB.png

    Here - when flash is enabled:
    http://i.imgur.com/MJU5hEn.png

  • Enable the html5-player here: https://www.youtube.com/html5

    You can also enable “Click to play” in Opera’s settings (opera://settings/), or block plugins on YouTube in opera://settings/contentExceptions#plugins.

    BTW, most videos are now encoded with VP9. B)

  • Thanks for reply. I HAVE html5-player enabled. But most videos are probably coded in vp8, because after opening video, for a second is shown message that codec is missing and player is automaticaly switched to flash version. If these videos would be in vp9, they were opened by html5 player.
    When I turn off flash plugin, then the same video is properly played as html5.

  • VP8 is now used only for low definition (640×360). VP9 is used for all definitions, including 3840×2160, but not yet for all videos.

    Here is an update on WebM/VP9: https://plus.google.com/108064614949575764375/posts/d5pTR7soe18

    Did any of my other suggestions work for you?

  • Unfortunately not. I don't know if you properly understand what is my issue.

    1. When I set: player html5 and flash plugin enabled, EVERY youtube video is opened as flash.
    2. When I set: player html5 and flush plugin disabled, most youtube videos are opened as html5 objects.

    Am I the one person how have this issue?

    Please try to play e.g. https://www.youtube.com/watch?v=VxvDVhjALoU with setting 1) - do you see flash or html5 video?

  • Unfortunately not. I don't know if you properly understand what is my issue.

    1. When I set: player html5 and flash plugin enabled, EVERY youtube video is opened as flash.
    2. When I set: player html5 and flush plugin disabled, most youtube videos are opened as html5 objects.

    Am I the one person how have this issue?

    Please try to play e.g.:
    https://www.youtube.com/watch?v=VxvDVhjALoU

    with setting 1) - do you see flash or html5 video?

  • I don't know why I can't add youtube link to video
    https://www.youtube.com/watch?v=VxvDVhjALoU

  • I got the YouTube-link in the email-notification.

    HTML5 (VP9) is used, with Flash Player enabled or disabled.

    Did you try to add an exception for YouTube in opera://settings/contentExceptions#plugins (and set the behaviour to Block)?

    Which version of Opera do you use? I use 25.0.1606.0 (on Ubuntu) with Flash Player 15.0.0.114 from Chrome beta.

  • It's because of PATCH-1164 http://blogs.opera.com/desktop/2013/12/youtube-is-back/

  • joakimwallden - yes, I tried to add exception and it did not help. I use Opera 24.0.1558.53 on Mac with Flash PLayer 14.0.0.176

    rafaelluik - what about this patch? How can I uninstall it?

  • Videos and channels on YouTube that features on-video or preroal advertisements will prefer the Flash plug-in over HTML5.

  • @aeyoun Daniel, please pay attention to my post. (I've already indicated that to you before in the DISQUS comments.)

    Flash is being forced in YouTube by you with the PATCH-1164 BrowserJS because YouTube was 1. bugging in Opera browser 2. not giving it access to higher resolution videos. Check the bug tracker for the patch, check OTW-9353.

  • Flash is not forced for me. My setting on https://www.youtube.com/html5 is respected, even when there is no VP9-video and all Opera can play is the VP8-fallback at 640×360.
    And yes, I have Flash Player (15.0.0.152) and it is enabled, and used on YouTube if I choose to use the default player.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.