Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Error Message Your Connection Is Not Private When Accessing GMail

  • Me too, sometimes it works but i do nothing and then again I have this error. I think it's an Opera Gx problem and they have to fix it.

    With other browsers it works fine.

  • I am having this same issue since yesterday. Can't seem to find a way to fix it.

  • I have the same problem. It started a day or two ago, after I updated windows.

  • I report the issue to Opera (DNAWIZ-129020) Gmail Issue - NET::ERR_SSL_PINNED_KEY_NOT_IN_CERT_CHAIN

    We'll see if they say something. Because it's just in Opera.

  • Same issue.

    Opera GX updated today to 73.0.3856.431 then this started happening.

  • I have the same issue

  • I'm dealing with the same problem, I tried to call my internet service to solve it, but it was in vain

  • Hello. I have a problem with opera gx, when I go to, I get a message from the page that "privacy error" and in the certificates tab it says that the certificate is not valid what should I do. And I checked on other browsers and it doesn't work only in opera and opera gx doesn't work. Can I get a quick reply?

  • Additional info for the ones taking an in depth look: A Win10 x64 update came in today: KB5001330

    So either the latest Opera GX update 73.0.3856.431 or the latest windows update (or both combined), seem to be triggering the issue.

    However , this doesn't happen on Chrome, for example, as someone mentioned earlier. So this leaves me wondering it's not related to the windows update specifically, unless Opera uses a specific windows feature modified in that update, that Chrome doesn't. Otherwise chrome would be affected as well.

  • I have the same problem and I noticed that on the top corner shows not safe conection and invalid certificated.

  • Everytime I try to access Gmail I get an error:


    It's working normally on every other browser I have (Firefox, Chrome, Brave and Edge).

    What I've tried so far:
    • Restart browser
    • Check for updates
    • Restart Computer
    • Check up if the internet is set as private
    • Renew and Flush DNS
    • Changing DNS from manual to automatic (provided by my ISP).
    /None of the troubleshooting above resolved the issue/

    I'm getting this error since yesterday, sometimes It works but after a few minutes I get the same error back.

    Some people on Reddit are getting the same error as well (In the last 24h). This post is just a Feedback (since I wasn't able to find a proper feedback form on the website).

  • I know a workaround, enable built-in VPNs in Opera

  • @burytomorow I haven't installed updates since last month, same problem.

  • @awfool Same here. The site is full of complaints about this Opera GX issue as well. I've tried turning the VPN on and off as a bonus, and updated the browser, but no luck.

  • I made an account just to say this. I also get an error saying "ERR_FAILED" for gmail only. Google docs, youtube, everything else works. Only this. I tried gmail on chrome and it works flawlessly. Only opera gx. Please fix. I'm considering switching browsers because there are so many bugs with this browser. Like how you have to disable dark mode in another setting site for opera or things will be some white some dark. This browser is giving me so many headaches.

  • I've opened a bug report issue to Opera Gx today but they don't give me a reply. I'm still waiting

  • @lcerica They won't reply to you as clearly said in the confirmation message you received.

  • I have the same issue, I already tried clearing SSL Cache, Reinstalling Opera this last one worked for a bit but then the message started to appear again.

  • Getting the same error, love Opera GX but lately its been very frustrating to use it 😢

  • I finally got this to happen to me in Opera GX. I then went to the URL opera://settings/system and enabled "Use DNS-over-HTTPS instead of the system’s DNS settings". Then things starting working. I don't know if that's coincidence or not yet though.